"Almost done" and "This may not be for you" issue

Copper Contributor

I am having issues with my account and cannot view any shared videos at all within my company. All my colleagues can view the videos which have been shared company wide, my account is in the email invite auto complete list and direct email invites do not work either (using the auto complete i get no email and still cant access the video).

This leads me to believe my account itself is somehow corrupt as i always get asked to sign up on first login, when i get past the usual dialogs stating im already signed up and have a licence i get stuck on the "almost done" setting up account page/video. Theres no links on this page and after waiting hours the first time i assumed it glitched so retried to link i was shared. As im now signed into a session it goes to the video but says i do not have permission to view it even though i do.

I tried searching this community for the "Almost done" stuck issue and the permissions issues but for the first its a archived result that said to use a workaround to login (tried that, didnt work) and ended before any clear fix was mentioned. The second gives the obvious responses about how permissions works.

Does anyone know how to reset my account somehow? the site seems painfully under developed (feature wise) so my options are pretty much nothing to attempt to resolve this.

0 Replies