Out of the blue Microsoft Teams tab will not load a MS Stream channel

Copper Contributor

I use Teams for holding synchronous class sessions.  I record these sessions and the videos are saved to a MS Stream channel.  I then created a tab in my Main Classroom channel on Teams which linked to this Stream channel.  Videos would then load and it was a convenient spot for students to view the videos.  This has worked fine for a month, until until today.  Now I get:




This doesn't happen when on the web-based Teams app, but does on the Mac Teams app.  Any ideas?


13 Replies

@jssgallagher  I am having the same problem. Multiple devices. I can access my Stream channels and videos, but my students cannot.  They get that same error message as you "Failed to load this channel".  When I direct them to go to Stream from Chrome instead of through Teams, they still have trouble accessing the channels. Sometimes it works, sometimes it doesn't....but it is failing more frequently since the latest Microsoft 365 update.


As of now it seems the problem is limited to the Teams MAC app. I link the Stream channel and Teams site in Canvas and students have been able to access the video that way. Since the problem arose suddenly for the Teams app, who knows if other connectivity issue will arise.

I was just alerted to this bug by  a co-worker. I was able to reproduce the same error within Teams. We're both using the full Windows desktop app. Found a Reddit Forum  full of others experiencing the same issue.  @jssgallagher

check the service health advisories.

We have the same issue(Channel is not able to load) in our tenant from 29/05.




We have the same issue - I noticed it a few days ago - our Streams Channel was not loading properly on the WINDOWS TEAMS app or the iOS Teams app.


@jssgallagherI've just hit the same issue, although it loads fine on the web browser version and my windows laptop but not my main windows PC. Both the laptop & the PC are running the same version of teams - (64bit). Quite strange!

@jssgallagher Same issue with me .. The channel was working just fine .. and then out of nowhere it just stopped with that error message Failed to load this channel, please try again

Same issue for us, although a subset of users.

@jssgallagher FYI Everyone, I just checked my desktop app now and it seems like the bug has been fixed.

Mine is now working, too! Thanks!

@jssgallagher I experienced the same issue a few days ago. I solved the issue relinked the URL of my Stream Channel in the tab. Right now it is working fine.