No Copy Button Microsoft Stream transcript VTT file cleaner

Copper Contributor

Attempting to use Microsoft Stream transcript VTT file cleaner to pull text out of a .VTT file.   I can upload the .vtt file using the browse button, but there is no COPY button has the instruction state.

Any suggestions? Thank in advance.


  1. As an owner of a video in Microsoft Stream, go to the Update video details screen
  2. On the details page for the video in Microsoft Stream, in the Options section, under Captions, click Download file
  3. Come back to this this transcript cleaner tool, click Choose Files
  4. Pick the VTT file(s) you downloaded from Microsoft Stream
  5. The transcript portion of the VTT file(s) selected will be output below
  6. click the Copy transcript button above a transcript to copy it to the clipboard
4 Replies

@sbrinsky - I just tested it and I have a copy button.  Can you try another browser, maybe your browser doesn't support whatever javascript command we used to copy to clipboard?


What browser and OS are you trying it on?



Windows 10 and Explorer. Thoughts?
best response confirmed by VI_Migration (Silver Contributor)
Microsoft Verified Best Answer

@sbrinsky - I would use the new Edge, Chrome, or FireFox. I tried on Internet Explorer 11 and it doesn't seem to work at all with the VTT Cleaner script. I would use a modern browser. I tested just now with Edge, Chrome, and FF, and they all worked fine for me. 

@Marc Mroz that seemed to be the trick. I used Firefox and all was well. thank you.