SOLVED

Possible bug with Remove-AipServiceTemplate cmdlet

%3CLINGO-SUB%20id%3D%22lingo-sub-1745814%22%20slang%3D%22en-US%22%3EPossible%20bug%20with%20Remove-AipServiceTemplate%20cmdlet%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1745814%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAccording%20to%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fpowershell%2Fmodule%2Faipservice%2Fremove-aipservicetemplate%3Fview%3Dazureipps%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fpowershell%2Fmodule%2Faipservice%2Fremove-aipservicetemplate%3Fview%3Dazureipps%3C%2FA%3E%26nbsp%3Bthis%20cmdlet%20should%20prompt%20for%20confirmation%20before%20letting%20you%20delete%20a%20template.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20found%20out%20today%20it%20does%20not%2C%20also%20whats%20worse%20is%20it%20lets%20you%20delete%20a%20template%20that%20is%20actually%20associated%20with%20a%20label%2C%20even%20with%20that%20label%20included%20in%20a%20policy.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnyone%20else%20able%20to%20confirm%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1745814%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAIP%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Visitor

Hi,

 

According to https://docs.microsoft.com/en-us/powershell/module/aipservice/remove-aipservicetemplate?view=azureip... this cmdlet should prompt for confirmation before letting you delete a template. 

 

I have found out today it does not, also whats worse is it lets you delete a template that is actually associated with a label, even with that label included in a policy.

 

Anyone else able to confirm?

1 Reply
Best Response confirmed by mrmotivator007 (Visitor)
Solution

Hi @mrmotivator007,

 

I can confirm: no prompt or warning before the template was deleted.

 

BR,

Mattia