Opening encrypted emails via OME app on iOS 10 or 11

%3CLINGO-SUB%20id%3D%22lingo-sub-117799%22%20slang%3D%22en-US%22%3EOpening%20encrypted%20emails%20via%20OME%20app%20on%20iOS%2010%20or%2011%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-117799%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20are%20having%20an%20issue%20opening%20encrypted%20emails%20via%20the%20OME%20app%20on%20iPhones%20(tested%20on%20iOS%2010%20and%2011).%26nbsp%3B%20This%20issue%20is%20independent%20of%20using%20the%20iOS%20mail%20app%20or%20the%20MS%20Outlook%20app.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EUsing%20these%20steps%20for%20testing%3A%3C%2FP%3E%3COL%3E%3CLI%3EReceive%20encrypted%20email.%20(Email%20is%20encrypted%20using%20Azure)%3C%2FLI%3E%3CLI%3EOpen%20the%20message.html%20attachment.%3C%2FLI%3E%3CLI%3ESelect%20%22Copy%20to%20OME%20Viewer%22%20option.%3C%2FLI%3E%3CLI%3ETap%20Use%20a%20one-time%20passcode%3C%2FLI%3E%3CLI%3EOpen%20email%20for%20one-time%20passcode%3C%2FLI%3E%3CLI%3ETap%20passcode%20and%20get%20redirected%20back%20to%20OME%20app%3C%2FLI%3E%3CLI%3EReceive%20the%20following%20message%2C%20%22This%20passcode%20is%20incorrect.%26nbsp%3B%20Please%20use%20the%20passcode%20with%20the%20correspoding%20reference%20code.%22%3C%2FLI%3E%3C%2FOL%3E%3CP%3EPlease%20note%2C%20if%20you%20enter%20the%20passcode%20manually%20into%20OME%20Viewer%20it%20works%20perfectly%20fine.%26nbsp%3B%20The%20issue%20is%20that%20you%20cannot%20copy%20the%20password%20because%20it's%20a%20link.%26nbsp%3B%20This%20makes%20the%20user%20have%20to%20flip%20back%20and%20forth%20between%20the%20OME%20Viewer%20and%20their%20email.%26nbsp%3B%20This%20is%20extremely%20frustrating%20for%20my%20staff%20and%20especially%20the%20partners%20of%20my%20company.%26nbsp%3B%20This%20used%20to%20work%20flawlessly%20and%20everyone%20really%20liked%20the%20process%2C%20but%20now%20it's%20viewed%20as%20cumbersome.%3C%2FP%3E%3CP%3E%3CBR%20%2F%3ECould%20someone%20please%20let%20me%20know%20if%20this%20is%20a%20known%20issue%20that's%20being%20worked%20on%20or%20if%20there%20is%20a%20work%20around%20that%20I'm%20not%20aware%20of%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20you!%3C%2FP%3E%3CP%3E-Mark%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-117799%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAzure%20Rights%20Management%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOME%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-143410%22%20slang%3D%22en-US%22%3ERe%3A%20Opening%20encrypted%20emails%20via%20OME%20app%20on%20iOS%2010%20or%2011%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-143410%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20also%20having%20exactly%20the%20same%20problem%20as%20Mark%20Neally.%3C%2FP%3E%0A%3CP%3EI'm%20sure%20it%20was%20working%20correctly%20a%20couple%20of%20months%20ago%20-%20i.e%20by%20tapping%20on%20the%20passcode%20in%20the%20email%20-%20it%20opened%20the%20portal.%20Now%20it%20asks%20to%20open%20in%20OME%20viewer%20which%20just%20brings%20up%20%22This%20passcode%20is%20incorrect.%26nbsp%3B%20Please%20use%20the%20passcode%20with%20the%20correspoding%20reference%20code.%22%3C%2FP%3E%0A%3CP%3ECould%20possibly%20have%20been%20caused%20by%20an%20IOS%20update%20from%20Apple%20I%20suppose%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3BMy%20iphone%20is%20on%20IOS%2011.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThis%20problem%20is%20preventing%26nbsp%3Bour%20business%20users%20from%20adopting%20this%20for%20secure%20comms%20with%20customers%20as%20it%20will%20confuse%20customers.%3C%2FP%3E%0A%3CP%3ECan%20anyone%26nbsp%3Bat%20Microsoft%20replicate%20the%20problem%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

We are having an issue opening encrypted emails via the OME app on iPhones (tested on iOS 10 and 11).  This issue is independent of using the iOS mail app or the MS Outlook app.

 

Using these steps for testing:

  1. Receive encrypted email. (Email is encrypted using Azure)
  2. Open the message.html attachment.
  3. Select "Copy to OME Viewer" option.
  4. Tap Use a one-time passcode
  5. Open email for one-time passcode
  6. Tap passcode and get redirected back to OME app
  7. Receive the following message, "This passcode is incorrect.  Please use the passcode with the correspoding reference code."

Please note, if you enter the passcode manually into OME Viewer it works perfectly fine.  The issue is that you cannot copy the password because it's a link.  This makes the user have to flip back and forth between the OME Viewer and their email.  This is extremely frustrating for my staff and especially the partners of my company.  This used to work flawlessly and everyone really liked the process, but now it's viewed as cumbersome.


Could someone please let me know if this is a known issue that's being worked on or if there is a work around that I'm not aware of?

 

Thank you!

-Mark

1 Reply

I'm also having exactly the same problem as Mark Neally.

I'm sure it was working correctly a couple of months ago - i.e by tapping on the passcode in the email - it opened the portal. Now it asks to open in OME viewer which just brings up "This passcode is incorrect.  Please use the passcode with the correspoding reference code."

Could possibly have been caused by an IOS update from Apple I suppose?

 My iphone is on IOS 11.  

This problem is preventing our business users from adopting this for secure comms with customers as it will confuse customers.

Can anyone at Microsoft replicate the problem?