Azure Infomation Protection Client is not getting installed in my Windows 10

%3CLINGO-SUB%20id%3D%22lingo-sub-324041%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20Infomation%20Protection%20Client%20is%20not%20getting%20installed%20in%20my%20Windows%2010%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-324041%22%20slang%3D%22en-US%22%3E%3CP%3EI%20had%20the%20same%20issue%20on%20Windows%2010%20when%20upgrading.%26nbsp%3B%20Rebooting%20didn't%20work%2C%20uninstalling%26nbsp%3Betc..%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20ended%20up%20searching%20for%20%22Azure%22%20in%20RegEdit%20and%20deleted%20two%20records%20similar%20to%20the%20ones%20in%20these%20screenshots.%20The%20Key%20name%20might%20be%20different%20for%20but%20if%20you%20search%20for%20Azure%20in%20that%20general%20area%20and%20find%20these%20delete%20them.%26nbsp%3B%20I%20just%20deleted%20the%20whole%20key%20and%20sub%20contents%20(MAKE%20BACKUPS%20FIRST%2C%20OR%20USE%20ON%20A%20NON-PRODUCTION%20TEST%20MACHINE)%20then%20tried%20to%20reinstall%20immediately%20worked%2C%20I'm%20now%20back%20to%20labeling%20files.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-319601%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20Infomation%20Protection%20Client%20is%20not%20getting%20installed%20in%20my%20Windows%2010%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-319601%22%20slang%3D%22en-US%22%3EI%20also%20have%20this%20problem...%20Office%20365%20installed.%20Can't%20rollback%20for%20some%20reason%2C%20says%20the%20newer%20version%20is%20installed.%20Reboot%20does%20not%20fix%20the%20issue.%20Nor%20does%20re-registering%20the%20installer.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-502492%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20Infomation%20Protection%20Client%20is%20not%20getting%20installed%20in%20my%20Windows%2010%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-502492%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F237813%22%20target%3D%22_blank%22%3E%40Jason%20Purviance%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20had%20the%20same%20error%2C%3C%2FP%3E%3CP%3Emy%20search%20was%20for%3A%26nbsp%3B%22Microsoft%20Azure%20Information%20Protection%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20registry%20keys%20i%20had%20to%20delete%20were%3A%3C%2FP%3E%3CP%3E%5BHKEY_CLASSES_ROOT%5CInstaller%5CProducts%5C81F60A84C159AC24681F0364FA601DE5%5D%3C%2FP%3E%3CP%3E%5BHKEY_CLASSES_ROOT%5CInstaller%5CProducts%5C993BF6477B270F046B2A7D4C218275F2%5D%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAfterwards%20the%20installation%20was%20completed.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-292554%22%20slang%3D%22en-US%22%3EAzure%20Infomation%20Protection%20Client%20is%20not%20getting%20installed%20in%20my%20Windows%2010%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-292554%22%20slang%3D%22en-US%22%3E%3CP%3EAzure%20Information%20Protection%20Client%20is%20not%20getting%20installed%20and%20an%20error%20message%20appears%20as%20%22The%20error%20code%202753.%22%20as%20shown%20in%20the%20below%20screenshot.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22image.png%22%20style%3D%22width%3A%20940px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F60955iDCA788DF05793712%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22image.png%22%20alt%3D%22image.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECan%20anyone%20tell%20me%20how%20to%20resolve%20this%20issue%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20in%20Advance%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-292554%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EInformation%20Protection%20%26amp%3B%20Governance%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Information%20Protection%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ERights%20Management%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1904884%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20Infomation%20Protection%20Client%20is%20not%20getting%20installed%20in%20my%20Windows%2010%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1904884%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F19201%22%20target%3D%22_blank%22%3E%40Ofir%20Doron%3C%2FA%3E%26nbsp%3BI%20made%20a%20one-liner%20to%20remove%20the%20keys%20which%20should%20make%20your%20life%20much%20easier.%26nbsp%3B%3C%2FP%3E%3CPRE%20class%3D%22lia-code-sample%20language-applescript%22%3E%3CCODE%3Efor%20%2Ff%20%22tokens%3D1%22%20%25%25a%20in%20('reg.exe%20query%20%22HKCR%5CInstaller%5CProducts%22%20%2Ff%20%22Microsoft%20Azure%20Information%20Protection%22%20%2Fs%20%20%5E%7Cfindstr%20%2Fri%20%22Installer%22')%20do%20reg%20delete%20%22%25%25a%22%20%2Ff%3C%2FCODE%3E%3C%2FPRE%3E%3CP%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor

Azure Information Protection Client is not getting installed and an error message appears as "The error code 2753." as shown in the below screenshot.

 

image.png

 

 

Can anyone tell me how to resolve this issue?

 

Thanks in Advance

4 Replies
I also have this problem... Office 365 installed. Can't rollback for some reason, says the newer version is installed. Reboot does not fix the issue. Nor does re-registering the installer.

I had the same issue on Windows 10 when upgrading.  Rebooting didn't work, uninstalling etc..

 

I ended up searching for "Azure" in RegEdit and deleted two records similar to the ones in these screenshots. The Key name might be different for but if you search for Azure in that general area and find these delete them.  I just deleted the whole key and sub contents (MAKE BACKUPS FIRST, OR USE ON A NON-PRODUCTION TEST MACHINE) then tried to reinstall immediately worked, I'm now back to labeling files. 

@Jason Purviance

 

I had the same error,

my search was for: "Microsoft Azure Information Protection"

 

The registry keys i had to delete were:

[HKEY_CLASSES_ROOT\Installer\Products\81F60A84C159AC24681F0364FA601DE5]

[HKEY_CLASSES_ROOT\Installer\Products\993BF6477B270F046B2A7D4C218275F2]

 

Afterwards the installation was completed.

 

@Ofir Doron I made a one-liner to remove the keys which should make your life much easier. 

for /f "tokens=1" %%a in ('reg.exe query "HKCR\Installer\Products" /f "Microsoft Azure Information Protection" /s  ^|findstr /ri "Installer"') do reg delete "%%a" /f