Microsoft Entra Suite Tech Accelerator
Aug 14 2024, 07:00 AM - 09:30 AM (PDT)
Microsoft Tech Community

Onboarding macOS into Purview DLP does not work

Copper Contributor

I'm currently trying to onboard a macbook into purview dlp using the following link;

https://learn.microsoft.com/en-us/purview/device-onboarding-offboarding-macos-intune

the macbook is already enrolled into intune via the installed company portal app

i tried to sync multiple times from intune portal, restarting the macbook and check status from company portal app on the macbook, assigned to group containing the user and then switching to group containing the device but nothing seems to work.

2 Replies

Hi @ViktorMalum,

There are a few things you can check to troubleshoot why onboarding macOS into Purview DLP using Intune is not working:

  1. Make sure that the macOS device is running a supported version of macOS. Purview DLP supports the three most recent major releases of macOS.
  2. Make sure that the macOS device is enrolled in Intune and the Company Portal app is installed.
  3. Make sure that the macOS device is assigned to a group that contains the Purview DLP onboarding package.
  4. Make sure that the Purview DLP onboarding package has been deployed to the macOS device. You can check the status of the onboarding package in the Intune console.
  5. Restart the macOS device.

If you have checked all of the above and onboarding is still not working, you can try the following:

  1. Clear the Intune cache on the macOS device. To do this, go to System Preferences > Profiles > Company Portal and click Remove Profile. Then, reinstall the Company Portal app from the App Store.
  2. Re-enroll the macOS device in Intune.


Please click Mark as Best Response & Like if my post helped you to solve your issue.
This will help others to find the correct solution easily. It also closes the item.


If the post was useful in other ways, please consider giving it Like.


Kindest regards,


Leon Pavesic
(LinkedIn)

com.microsoft.dlp is not enableing for DLP, after enabling this manually from machine changing the status to "active" instead of "unhealty".



I have deplyed nokext.mobileconfiguration configuration profile, but it's not helping me to enable this. Availibility and Full Disk Acess is showing not installed in Microsoft Purview console. After manually enableing it's change to installed.



Please advise how can enable this with the help of JAMF?