Work with Power BI visuals - lab08 - issues when loading data through live connection

%3CLINGO-SUB%20id%3D%22lingo-sub-2043404%22%20slang%3D%22en-US%22%3EWork%20with%20Power%20BI%20visuals%20-%20lab08%20-%20issues%20when%20loading%20data%20through%20live%20connection%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2043404%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3EOn%20Lab%2008%20from%20%22Work%20with%20Power%20BI%20visuals%22%2C%20I%20am%20having%20issues%20on%20getting%20the%20data%20when%20reaching%20the%20%22Create%20a%20live%20connection%22%20section.%20Everything%20is%20working%20fine%20until%20I%20get%20to%20that%20point.%20I%20can%20choose%20the%20data%20correctly%20but%20when%20I%20create%20the%20report%20according%20to%20the%20instructions%20below%2C%20then%20I%20am%20able%20to%20see%20all%20the%20tables%20on%20the%20right%2C%20but%20they%20bring%20no%20data%20at%20all.%20Please%20see%20the%20attached%20picture%20to%20better%20understand%20the%20issue.%20I%20went%20through%20the%20instructions%20several%20times%20but%20still%20can%C2%B4t%20get%20the%20data%20into%20it.%20Even%20more%2C%20if%20I%20look%20into%20the%20Sales%20analysis%20dataset%20mentioned%20in%20point%20%232%2C%20I%20can%20see%20the%20data%20without%20issues.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECreate%20a%20live%20connection%3C%2FP%3E%3CP%3EIn%20this%20task%2C%20you%20will%20create%20a%20live%20connection%20to%20the%3CFONT%20face%3D%22Segoe%20UI%22%3E%26nbsp%3B%3C%2FFONT%3E%3CSTRONG%3ESales%26nbsp%3BAnalysis%3C%2FSTRONG%3E%3CFONT%20face%3D%22Segoe%20UI%22%3E%26nbsp%3B%3C%2FFONT%3Edataset.%3C%2FP%3E%3COL%3E%3CLI%3E%3CP%3ETo%20create%20a%20live%20connection%2C%20on%20the%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CSTRONG%3EHome%3C%2FSTRONG%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3Eribbon%20tab%2C%20from%20inside%20the%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CSTRONG%3EData%3C%2FSTRONG%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3Egroup%2C%20click%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CSTRONG%3EGet%26nbsp%3BData%3C%2FSTRONG%3E%2C%20down-arrow%2C%20and%20then%20select%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CSTRONG%3EPower%26nbsp%3BBI%26nbsp%3BDatasets%3C%2FSTRONG%3E.%3C%2FP%3E%3C%2FLI%3E%3CLI%3E%3CP%3EIn%20the%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CSTRONG%3ESelect%26nbsp%3Ba%26nbsp%3BDataset%26nbsp%3Bto%26nbsp%3BCreate%26nbsp%3Ba%26nbsp%3BReport%3C%2FSTRONG%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3Ewindow%2C%20select%20the%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CSTRONG%3ESales%26nbsp%3BAnalysis%3C%2FSTRONG%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3Edataset.%3C%2FP%3E%3CDIV%20class%3D%22mx-imgBorder%22%3E%3CDIV%20class%3D%22mceNonEditable%20lia-copypaste-placeholder%22%3E%26nbsp%3B%3C%2FDIV%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FDIV%3E%3C%2FLI%3E%3CLI%3E%3CP%3EClick%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CSTRONG%3ECreate%3C%2FSTRONG%3E.%3C%2FP%3E%3C%2FLI%3E%3CLI%3E%3CP%3EAt%20the%20bottom-right%20corner%2C%20in%20the%20status%20bar%2C%20notice%20that%20the%20live%20connection%20has%20been%20established.%3C%2FP%3E%3C%2FLI%3E%3CLI%3E%3CP%3EIn%20the%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CSTRONG%3EFields%3C%2FSTRONG%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3Epane%2C%20notice%20that%20the%20data%20model%20tables%20are%20listed.%3C%2FP%3E%3CP%3E%3CEM%3EPower%26nbsp%3BBI%26nbsp%3BDesktop%20can%20no%20longer%20be%20used%20to%20develop%20the%20data%20model%3B%20in%20live%20connection%20mode%2C%20it's%20only%20a%20report%20authoring%20tool.%20It%20is%20possible%2C%20however%2C%20to%20create%20measures%2C%20but%20they%20are%20measures%20that%20are%20only%20available%20within%20the%20report.%20You%20won't%20add%20any%20report-scoped%20measures%20in%20this%20lab.%3C%2FEM%3E%3C%2FP%3E%3C%2FLI%3E%3CLI%3E%3CP%3ESave%20the%20Power%26nbsp%3BBI%26nbsp%3BDesktop%20file.%3C%2FP%3E%3C%2FLI%3E%3C%2FOL%3E%3CP%3EYou're%20the%20owner%20of%20the%20Power%20BI%20dataset%2C%20and%20you%20can%20see%20all%20data.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2063930%22%20slang%3D%22en-US%22%3ERe%3A%20Work%20with%20Power%20BI%20visuals%20-%20lab08%20-%20issues%20when%20loading%20data%20through%20live%20connection%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2063930%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F922230%22%20target%3D%22_blank%22%3E%40Fedee_t%3C%2FA%3E%26nbsp%3BI%20have%20the%20same%20issue.%20There%20doesn't%20seem%20to%20be%20any%20support%20for%20this.%26nbsp%3B%3CIMG%20class%3D%22lia-deferred-image%20lia-image-emoji%22%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Fhtml%2Fimages%2Femoticons%2Fsad_40x40_1.gif%22%20alt%3D%22%3Asad%3A%22%20title%3D%22%3Asad%3A%22%20%2F%3E%3C%2FP%3E%3CP%3EIt%20doesn't%20get%20any%20better%20in%20LAB09%20when%20you%20have%20to%20use%20it%20again.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHave%20you%20found%20a%20way%20to%20get%20around%20it%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2064004%22%20slang%3D%22en-US%22%3ERe%3A%20Work%20with%20Power%20BI%20visuals%20-%20lab08%20-%20issues%20when%20loading%20data%20through%20live%20connection%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2064004%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F929695%22%20target%3D%22_blank%22%3E%40RHamilton41%3C%2FA%3E%26nbsp%3BUnfortunately%20there%20is%20no%20support%20and%20it%20gets%20worst%20when%20trying%20to%20move%20forward%20in%20the%20next%20labs.%20The%20only%20thing%20I%20could%20do%20was%20to%20do%20the%20next%20labs%20without%20data%20and%20assume%20that%20I%20was%20understanding%20all%20the%20effects.%20For%20many%20things%20like%20formatting%20we%20don%C2%B4t%20need%20the%20data%20but%20it%20is%26nbsp%3Ba%20really%20annoying%20don%C2%B4t%20being%20able%20to%20use%20the%20labs%20properly.%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Hi,

On Lab 08 from "Work with Power BI visuals", I am having issues on getting the data when reaching the "Create a live connection" section. Everything is working fine until I get to that point. I can choose the data correctly but when I create the report according to the instructions below, then I am able to see all the tables on the right, but they bring no data at all. Please see the attached picture to better understand the issue. I went through the instructions several times but still can´t get the data into it. Even more, if I look into the Sales analysis dataset mentioned in point #2, I can see the data without issues.

 

Create a live connection

In this task, you will create a live connection to the Sales Analysis dataset.

  1. To create a live connection, on the Home ribbon tab, from inside the Data group, click Get Data, down-arrow, and then select Power BI Datasets.

  2. In the Select a Dataset to Create a Report window, select the Sales Analysis dataset.

     

     

  3. Click Create.

  4. At the bottom-right corner, in the status bar, notice that the live connection has been established.

  5. In the Fields pane, notice that the data model tables are listed.

    Power BI Desktop can no longer be used to develop the data model; in live connection mode, it's only a report authoring tool. It is possible, however, to create measures, but they are measures that are only available within the report. You won't add any report-scoped measures in this lab.

  6. Save the Power BI Desktop file.

You're the owner of the Power BI dataset, and you can see all data.

 

 

 

 

 

3 Replies

@Fedee_t I have the same issue. There doesn't seem to be any support for this. :sad:

It doesn't get any better in LAB09 when you have to use it again.

 

Have you found a way to get around it?

@RHamilton41 Unfortunately there is no support and it gets worst when trying to move forward in the next labs. The only thing I could do was to do the next labs without data and assume that I was understanding all the effects. For many things like formatting we don´t need the data but it is a really annoying don´t being able to use the labs properly.

@Fedee_t 

 

Thank you for getting back to me. I think another work-around is just to do the labs within the Lab08 starter. Ignore the first 3 pages already in the file and just start page 4 with 'Overview'.

 

I think the issue is with the refresh of the file that we upload as part of the exercise. It doesn't have credentials to refresh.

 

Best wishes.