The property is missing a required prefix/suffix per your organization's Group naming requirements

Contributor

Hello All,

 

My Organization enabled 'Group naming policy' in Azure AD.

Current Policy:

<Group name>(<Company>)

 

It works perfectly when I try to create new teams through Teams App but We are facing issue when I try to create a Teams through CSOM based provisioning jobs.

 

We are appending the Company Name suffix to the group name like below

Ex. TestTeam(CompanyName)

But still it is throwing below error:

 

Code: Request_BadRequest
Message: The property is missing a required prefix/suffix per your organization's Group naming requirements.
Details:
	Detail0:
		Code: MissingPrefixSuffix
		Target: displayName
		AdditionalData:
	suggestedPropertyValue : sid-12-18-2021(MyCompany)()
Inner error:
	AdditionalData:
	date: 2020-12-18T06:08:56
	request-id: 2d495a06-22d7-4d6b-a92a-1e1ad24e2193
	client-request-id: 2d495a06-22d7-4d6b-a92a-1e1ad24e2193
ClientRequestId: 2d495a06-22d7-4d6b-a92a-1e1ad24e2193

 

 

Code snippet I am referring below:

 

 

 UnifiedGroupEntity unifiedGroupEntity = UnifiedGroupsUtility.CreateUnifiedGroup(unifiedGroupInformation.DisplayName, unifiedGroupInformation.Description,
                    unifiedGroupInformation.MailNickname, accessToken, unifiedGroupInformation.Owners,
                    null, true, true, 10, 500);

 

 

Thanks.

BR. Sid

2 Replies
This community is for things related to Microsoft Learn and Microsoft Certifications. I would recommend reaching out on the Microsoft Azure Active Directory Community https://techcommunity.microsoft.com/t5/azure-active-directory-identity/ct-p/AzureActiveDirectory or Microsoft Q&A https://docs.microsoft.com/en-us/answers/products/azure