Implement a hub-spoke network topology on Azure Exercise - fails

Occasional Contributor

I am using the Azure sandbox to do the hub and spoke exercise (https://docs.microsoft.com/en-us/learn/modules/hub-and-spoke-network-architecture/4-exercise-impleme...

The creation of deployment group give an error in the CLI


suresh_thomas@Azure:~$ az deployment group create \
> --resource-group learn-42216600-6ffe-4669-8cca-5bd0ca6ad936 \
> --template-uri https://raw.githubusercontent.com/MicrosoftDocs/mslearn-hub-and-spoke-network-architecture/master/az...
Deployment failed. Correlation ID: d1d1dd1b-ad6f-460f-9f51-63188afa028b. {
"error": {
"code": "AnotherOperationInProgress",
"message": "Another operation on this or dependent resource is in progress. To retrieve status of the operation use uri: https://management.azure.com/subscriptions/d0f92735-9250-4609-81e2-b548bb3cb72d/providers/Microsoft.....",
"details": []
}
}
Any idea 

2 Replies

Hello @sureshthomas

 

I just verified the lab and it worked flawless for me. I may have been a brief moment where two deployments were running in parallel. Did you try to run the script twice by any chance?

I suggest that you just try it again as I would do in production too. Let me know how it went.

Cheers
Rolf
#MCT #LearnWithRolf #TheCloud42 

@Rolf-42  Thanks Rolf - its worked . It might have been  a temporary issue