AI-900 Labs cannot be started

New Contributor

Trying to complete the AI-900 course, I cannot get most of the Labs to work.

The lab for image classification started, but some internet filter prevented access to github.com, so I was unable to clone the required repository. :sad:

Hasn't anyone checked this lab?

 

All the other labs I've tried (object recognition, face recognition) won't even start and don't give any visible hint on what's wrong.

The browser console gave an uncaught exception in a promise with "Access Denied. The specified lab is not available to this API consumer."

I even tried my private account because the "known issues" contained something about troubles with ...onmicrosoft.com-accounts, but to no avail.

 

Can someone please check the labs and make them work?

 

Thanks,

Martin Müller

 

9 Replies
Where are you trying to run the labs? Is this a sandbox in Microsoft Learn, a lab provided by Skillable, godeploy, or another lab hoster, or your own computer?

Which repo are you using https://github.com/MicrosoftLearning/AI-900-AIFundamentals or https://github.com/MicrosoftLearning/mslearn-ai900

@Julian Sharp I'm trying to start them from MS Learn.

The image classification lab tells you to clone the repository github.com/MicrosoftLearning/AI-102-AIEngineer, but github.com is giving timeouts from within VS Code and from a shell, even though github.com can be pinged successfully.

Trying to open github.com/MicrosoftLearning in the browser came up with a web filter alert.

 

Best regards,

Martin

Are you completing AI-900 or AI-102, I am confused. Can you provide a link to the MS Learn module as it works for me for this
https://docs.microsoft.com/en-gb/learn/modules/analyze-images-computer-vision/3-analyze-images

PS /home/julian> git clone https://github.com/MicrosoftLearning/AI-900-AIFundamentals ai-900
Cloning into 'ai-900'...
remote: Enumerating objects: 365, done.
remote: Counting objects: 100% (365/365), done.
remote: Compressing objects: 100% (257/257), done.
remote: Total 365 (delta 179), reused 269 (delta 88), pack-reused 0
Receiving objects: 100% (365/365), 16.23 MiB | 1.70 MiB/s, done.
Resolving deltas: 100% (179/179), done.
PS /home/julian>
Hi Julian!
I've found it again: I was talking about the lab from here:
https://docs.microsoft.com/en-us/learn/modules/classify-images/5-exercise-custom-vision
In this VM, some network access settings prevented me from accessing github.

The other problem that most other "Start lab" buttons (e.g. the one here: https://docs.microsoft.com/de-de/learn/modules/detect-objects-images-custom-vision/3-create-object-d...) are unable to start a lab persists.

Yes, I am seeing this on the sandbox VM, Github.com is blocked
Try the English version of the lab https://docs.microsoft.com/en-gb/learn/modules/detect-objects-images-custom-vision/3-create-object-d.... They seem to have gone away from Sandbox VMs to just using Cloud Shell
I am going to see if I can raise this problem but am trying to find out where
Great! I wasn't aware that different language versions actually use different technologies. That was part of my problem as well finding the URL where the problem first occurred. I didn't remember exactly, so I was searching for "mslearn image classification" and was puzzled why I didn't find the VM-based lab on the (english) search results anymore...
Hi
The blocking of GitHub has been resolved and I have been able to clone the GitHub repo for AI-102 in the https://docs.microsoft.com/en-gb/learn/modules/analyze-images/5-exercise-computer-vision lab