Windows 11 Autopilot and language packages

Copper Contributor

Hi everyone,

I work for a Company with about 10.000 employees. We have a working SCCM envoirenment and an Autopilot PoC which should go live in the near future. The whole project was in cooperation with DELL. The problem here is that DELL scammed us a little bit, because they always ensured us, that we will get the DELL ready image for the region where Notebook is deployed (DELL ready Image contains the LPs for all countries in the Region e.g. central Europe, Asia pecific etc.). 

At the End Dell told us, that it us technically not possible to provide us this image and the only thing they can do is to provide us the basic US image

That's where our problem started...

We need some languages for our subsidaries in some countries.

Thus we tried to create a package for the Language install.

1. First idea was to use the Powershell cmdlet install-language (Install-Language (LanguagePackManagement) | Microsoft Learn). The problem here is that this package runs pretty unstable. During Autopilot the command needs about 30 Minutes to finish. Sometimes the command throws an error: "Language Pack or feature could only be partially installed. Error Code: -2147023436“ (I guess it is a timeout but I didn't find anything on Google). 

The strange thing here is that this cmdlet runs pretty good and stable in private envoirenment. I tested it on my PC at home with Windows 10 22H2 and on a company device with the Microsoft en-US base Image (Win 11 23H2).

With Autopilot it worked 70-80% of the time and the rest failed. It was very strange that in the logs the cmdlet faild with error Code: -2147023436, but after Autopilot finished, the Language was available if I called get-language. I also monitored it in the OOBE with the powershell. Result: cmdlet sometimes failed, Language was av

Does anyone know how install-language works in the Background? Which URLs are called or what this error code means?

Thank you for every kind of help

Best regards


5 Replies
Did you even read, what I wrote?
By the way we tried the script and it has the same behaviour. The most time it works and sometimes it failes...

We have exact the same problem, it looks like WSUS (SCCM) causing this issue, as when I login to computer where is EN-EN language only and is properly enrolled then I'm getting the same error when I just run Install-Language command in PowerShell, I think this command is using Windows Update service for downloading LIP from MS.


What does the log tells?
Does it shows this:
"Language Pack or feature could only be partially installed. Error Code: -2147023436"
Do you know what really is issue in my case, SCCM client deployment need go after LIP deployment as install-language command trying to reach internet via Windows Update but if you deploy SCCM client before LIP deployment then install-language trying to download LIP from SCCM server. Change order of deployment and move LIP deployment script before SCCM client and all works.