Windows 10 1903 Autopilot always fails at user app deployment stage

Brass Contributor

Testing the recently released 1903 with two Autopilot tenants and with both they always fail at the user stage when trying to install apps. These apps are just normal store apps, Company Portal, Forticlient, Translator. If you skip waiting and install them manually, the setup completes, but it just won't install store apps by itself.


Anyone else had this issue? If not, I will get some logs.

44 Replies

@Coert Kastelein  this a known issue with the 1903 builds, I'm told the latest Insider Fast build (18881)  has the fix.  The bug was that all store app installs fail when using Intune or any MDM to install Microsoft Store for Business apps, they install like you said manually just fine.  Try the 18881 version  

Thanks for confirming Eric.

@Eric Orman  Would it be possible to share how I/ we can get the 18881 build? We are also trying to test Autopilot and it fails at the same point. Thanks in advance.

This is via Insider Program, not an .ISO you can install.
Run ms-settings:windowsinsider-optin


You will have to Autopilot reset the device after you updated it to 18881 to test the deployment.

@Coert Kastelein  Thanks for your response yesterday. I went through the steps you advised on build 18362.30, but the only build update I am offered is 18875.1000. Even though I selected the Fast ring without Skip ahead.

Did I do something wrong?  



@Darren Littlefield I tried the same and also not going beyond that version. I suppose MS engineers have even earlier access to these builds. Expecting it soon. Perhaps @Eric Orman can provide more info.

Got it working with 18885

@Coert Kastelein  That's good news.  Did you have to make any changes or do anything in particular? Or CP just works now?



No additional steps performed. When the deployment finished, all apps were installed where they'd fail before.

@Coert Kastelein  Just one question, isn't 18885 (20H1) the next build of Windows? This wont be the May release build?  As this was the 'skip ahead' version.  I want to make sure our business will be inline with the release version and not a version ahead.



It's even not the next, bet next next build. Next feature update should be 19H2 scheduled for October 2019. 20H1 is for 2020 spring update. Yeah, this is puzzling that MS jumps this much ahead and there are still no news about 19H2 testing. Btw, in May you will receive 19H1, 18362.xx build. Which i guess won't have that Autopilot fix. Maybe they will release it as a CU fix for the current version, who knows. Maybe they will add it to 19H2 release. Just guessing.
I'm not really sure how these branches join eachother when it comes to bug fixes. They advertise 1903 to be the first release that can fully configure a device during Autopilot deployment, so I don't think the fix for this bug will be introduced after the release of 1903.

Update:  Fix for this issue is expected/scheduled to be released in early May for 1903 builds.  

@Eric Orman Thanks for the update Eric. Will this be a new patched ISO available on MSDN, or will it be an update only?  As we are using autopilot with OOBE it would be time consuming to have to log in, update and then refresh to then autopilot the way we want to.  Thanks

@Eric Orman, has this been fixed in 1903 build 18362.113?

I just validated build 18362.113 and it still fails. :(

@Jose Castillo Soriano

1903 Washington released today. Is it a backend thing MS needs to flip? Nothing is mentioned here:
1903 was released today. Is it a backend thing MS needs to flip? Nothing is mentioned here:
best response confirmed by Coert Kastelein (Brass Contributor)

We are working on the fix for this.  It should be available in the cumulative updated released next week (5/28).