Wifi disconnects after Intune enrollment

New Contributor

During the setup of a new device, once we have run through the initial setup of region and keyboard and joined the wireless network we get to this screen to enrol in Intune.
We enter a valid username and password and it continues to device set up.
After that it says user name or password is incorrect.
Once OK is click it brings up the login screen where we can see the wireless has been disconnected.
I can then reconnect to the wireless and login fine with the same username and password I used earlier.


This only happens on wireless networks with WPA2 enterprise encryption. If I tether the device to my phone and run through the enrollment process after the device setup screen it loads straight into Windows with the user credentials entered. It stays connected to the wireless and doesn't have the screen saying user name or password is incorrect.


Does anyone know why the wireless is disconnecting?

Any advice is much appreciated.

Thank you.

Kind regards,

17 Replies

Does the wireless network have some type of Certificate or something it requires to be on a domain or something?


Is it just a normal home network?


Yes there is a certificate for the wireless network.


It works as expected when I tether to my phone.

We need to clear when certificates for wpa2-eap were installed.
If you want to install certificates with Intune, you should connect your computer to the internet first, without wpa2-eap.

Did you solve this issue?
Have also seen this behaviour at a customer with WPA-2 Enterprise secured wi-fi.


Hi all,


@clim_10did you work out what this was? I'm having exactly the same problem however I'm using RADIUS authentication against local AD on my school network to login to the WiFi and WPA2 encryption method with Auto (TKIP+AES) algorithm on a RUCKUS wifi network. I can sign into ADFS etc exactly like you, username and password works and then get the same error and disconnected. Once back at the login screen I can reconnect to WiFi with the same username and password exactly like you to which leads me to think its not the authentication method to WiFi but like you said something to do with the cert presented from the Wifi??


I also tried or a unrestricted WiFi AP whitelisted and let though the schools network with a normal WEP key, no web filter etc and it works fine so at has to be something to do with the WiFi or maybe web filter tho I don't see how??

We logged a support ticket with Microsoft and after some extensive troubleshooting it looks like this is not a "fault" rather an oversight, they did not forsee people using enterprise authentication for autopilot intune enrollment... It has since been handed over to the feature request team at Microsoft to add as a feature for a future update. No ETA yet...
Thanks very much for the quick reply....

Look like we need to setup another SSID with different Authentication/Encryption for the enrolment then for the time being!

@clim_10 Hi, we experience the same issues! Do you already have news about this issue? Do you have a casenumber or something for me to refer to?

I hope this issue is solved quickly


Thanks in advance.


@Vijfje5  I didn't log a call but we tried it on 1903 (manual upgrade) and it worked fine on that. Problem is there is no easy way to get the surface to 1903 beforehand at the moment so we are just stuck with it at the mo




I also see this behaviour on an enterprise WiFi with certificates, we encourage the technician or user to dock the machine during enrolment as it disconnects multiple times after each reboot.


Which exact version is that?

Any version before 1903 I believe

@ricksd I meant which version of 1903 you used and when the test was successful? Seen it failing on one of the Frist versions and prior 1903 versions indeed.


@Peter Klapwijknot exactly sure which version it was but we used the Windows 10 Update Assistant https://www.microsoft.com/en-gb/software-download/windows10 to upgrade about 3-4 weeks ago and this would have taken us right up to the latest version I believe.


I'm seeing this on 1903, standard laptop not a surface,


We have a WPA2 Enterprise WiFi where students log in with their own credentials via Radius,


Same issue, account setup works fine, but WiFi disconnects before the initial logon, can reconnect immediately by clicking the networking icon and pressing the connect button on the WiFi


Is there a call reference with Microsoft that anyone has for reporting it previously that we might be able to check on any progress?




@ChrisShearing Not as far as I know, but maybe someone else in the thread has a call?


@ChrisShearingHi Chris,

We need to clear these points,


1. "Connect Automatically" setting status
- Is it set to enable the wi-fi profile?
2. Is it connect automatically if you wait some minutes (5-10 minutes or 30 minutes)


You've connected with only click the button.
The profile is completely working.