SOLVED

w32 app only installs as part of Autopilot, never installs after device enrollment

Contributor

Hi,

 

I have such a weird issue that all w32 apps only installs if I assign them as part of the Autopilot process.

 

If I assign the w32 apps after the device is enrolled, it never installs. 

From Intune console, under the device, I can see the w32 app appear under the managed apps, showing waiting for installation status. It will forever wait and never fails, nor would it install.

 

If I look under the w32 app, the device does not show up under the status. It almost like the app cannot see its assignment group.

 

I have tried the IME log and couldn't find anything useful. Because it didn't install, nor did it fail. In fact, I don't think the package has been downloaded to the device.

 

Again, this only happens if I assign the w32 app after the device is enrolled and completed the Autopilot. If I assign the w32 apps as part of Autopilot, they install fine. But then they won't uninstall either because it is after the enrollment.

 

I don't exactly what is wrong. The w32 apps are installed under Device context as the PC is using Self-deploying kiosk mode with no user context.

 

Does anyone else have similar experience?

 

Thanks.

 

4 Replies

@wangjueliang

 

It seems an issue with Intune Management Extension, have you tried restarting the service? This will trigger an instant lookup for any new policy, the new install intent. 

The regular polling interval of the IME is every 60 minutes.

Can you check if you see anything under this folder (C:\Program Files (x86)\Microsoft Intune Management Extension\Content\Incoming)? IME starts the download the package from Intune into that folder before decrypting in the staging folder. 

I would also check the the IME logs file which you can find here (C:\programdata\microsoft\intunemanagementextension\logs\IntuneManagementextension.log)

 

best response confirmed by wangjueliang (Contributor)
Solution
Self-deploying kiosk mode and deploying NEW win32apps... that's seems to be an issue I am hearing a lot... not 100% sure... could be totally wrong (need to check ) but could you take a look at this registry key

HKEY_LOCAL_MACHINE\software\microsoft\enrollments\"ENROLLMENTGUID"\FirstSync\ and configure the SkipUserStatusPage with a value of 1 (or deploy the skipuserstatuspage csp :) )

Thanks for the reply.
My suspicion has always been that the device or Intune is not aware that the w32 app is required to install. In the Incoming folder, there is nothing there (I watched the folder for a bit once I started deploying). Also in the log, there is no obviously errors. There is no errors relating to the app at all, whether it is about downloading or installing.
Hi Rudy,

I followed Moe's suggestion above checking the logs, restarting IME service (although I didn't think so because in the past, I often reboot the PC to troubleshoot), there was nothing happening.

So I set the skipuserstatuspage value to "1" and rebooted the PC.
Soon enough (maybe less than 5 mins), the w32 installed, magically appeared on my desktop. About 10 mins later, the Intune console also showed the app is installed, both under the Device blade and App blade.

If this is the fix, what's left for me is to set it as a CSP to the device group as soon as it complete Autopilot.

Now can you tell me what is this setting and why it fixed my issue?
Is it because I am running a user-less set up?

Btw, our current configuration works fine with a mixture of Store apps and MSI installation. The reason I am changing them into a w32 setup is because many sources say, it is best not to mix app installation types and w32 is the best.

Thanks!