Microsoft Technical Takeoff: Windows and Microsoft Intune
Oct 24 2022 07:00 AM - Oct 27 2022 12:00 PM (PDT)

USB Block not removing

New Contributor

Hey All,


So i have set the Device Control policy to block USB connection and removable storage applied to a test user which logged in to a machine and the Mass Storage devices are not working perfect. 
Now i sent up an allow USB group which is the same policies above but just set to not configured and applied it to the test user the USB function is still blocked. the User and the PC are in the policy as succeeded with a green Tick.

Test user is completely removed from the USB Blocking Group. i have left it over night with a sync and reboot but it is not working. 

I have removed all USB Policies from Endpoint Manager all together and still USB will not work.

Am i missing something? is there an enable USB function that i have to enable?




4 Replies


Some settings are still tattoed when you remove the policy. Could you create a policy and a group where you make sure the usb is enabled?


I had the same issue with blocking language settings


The Device With The Dragon Tattoo - Call4Cloud

Hey Rudy,

Yes i have found a few articles on how to fix the issue, i have tried these but none of them have worked so far. I have tried what has been said here.
I will try to test it on a real device today.. :) I will post my results





Can you take a look at the registry on the device which is experiencing the problem? Just tested myself... WhenI set the policy to non configured and sync the device from intune... within a few minutes I can access the USB drive again


You could check out of there are lingering settings inside this key:

Normally this should be empty when you change the setting to not configured