Trying to learn Intune - stuck at MDM "Your device is already being manged by an organization"

New Contributor

I'm trying to learn Intune and Endpoint manager so I'm going through the Pluralsight course Implementing Mobile Device Management (MDM) with Microsoft Intune by Greg Shields.


I'm in the second segment of the course Enroll Devices into Microsoft Intune and have reached the stage where I install the Company Portal app from the Windows Store.


Installing the app, I successfully sign into one of the user AAD accounts, then go into the MDM part.


Company Portal - Set up your device.PNG

Clicking next

Company Portal - Connect to work.PNG

Clicking Connect

Company Portal - set up a work or school account.PNG

Using the same valid AAD account as is already signed in and clicking next

Company Portal - already managed.PNG


In Windows Settings, Accounts, Access work or school, the test user account is listed. Clicking info shows that it is managed by mddprov account.


There are no errors in the DeviceManagement-Enterprise-Diagnostics-Provider event log section.


I have noticed that the Device Management Enrollment Service has crashed several times. This is a clean new install of windows 10 pro in eval mode. The crash occurs when I open Company Portal. Exception code 0xc0000005 in module


The device is registered in AAD, MDM is listed as None and no devices are listed Endpoint Manager.


I'm lost as to a solution. If anyone has suggestions of how I can resolve this issue, I'd appreciate it.

11 Replies
best response confirmed by David-B (New Contributor)

The issue has been resolved. The default configuration was for MAM user scope to be set to All when it needs to be set to None.


To get to the correct screen, go to Microsoft Endpoint Manager, click Devices, Enroll Devices, click Automatic Enrollment. Changing MAM from All to None, unmanaging the devices currently in AAD, then adding them again via the Company Portal store app.




@David-B Hi David,


Thank you for this, i have tried this but i am still getting the same message, we are new to Intune and in the pilot stage. 


Can you assist any further?






I stumbled on your post while trying to find an answer to a similar problem. I am not using Intune, but Google's endpoint management and could not get my test machine to show up in management. Since I found my answer, I thought I'd share what I found on the off chance that the issues are the same.


I found what eventually pointed me in the right direction here:


I had to look in the Registry here:



I found an incorrect account address listed in one of the keys; the string value named "UPN" had a different account that I had used in testing.  Since you mentioned that you are new and in the pilot stage, I thought perhaps you might have also attempted enrollment on this a time or two before.


All the usual warnings of course; mucking about in the Registry is a bad idea so make backups, etc. I have no idea if my fix will translate to a fix for you. I hope that it does.




Hi David,


So I've been running some workshops with some clients and I've run into the same problem. It really sucked that it happend during a live demo but all assured I did some troubleshooting.


Apparently the Company Portal App is bugged...

Here are my settings:  MAM and MDM are set to all or can be set to some, it doesn't matter. They should work in tandem ...


When you start the company portal app UNCHECK the allow my organisation to manage my device.



Everything works smoothly afterwards. I don't even get why that option is there in the first place. Even if it's unchecked it still registers the device with Azure AD...

I simply proceed then to the allow the organisation to manage my device. It worked.


Hope it helps,




Hi, I guess everyone is wondering the same question. 


But working in tandem? Microsoft explains MAM and MDM very well




If you don't want to register the device, you will need to click on no, sign in to this app only



HKLM\SOFTWARE\Policies\Microsoft\Windows\WorkplaceJoin, "BlockAADWorkplaceJoin"=dword:00000001

Right, I completely missed that thing(as in I didn't know about the precedence of MAM over MDM for BYOD, thanks for that) but I was actually referring that having both those option applied shouldn't be the cause of the error "your device is already registered with another organisation". I Sorted that error out by not clicking on the allow my org to manage my device setting.
Sheesh, I'm confused.. oh well, get your troubleshooting boots on!

It's something that's quickly overlooked indeed. Old registry settings and old account connections could be the cause of the warning/error. When giving a demo, always make sure the device has a nice clean install :). I also made the mistake myself when I wanted to show something to a colleague
They are always clean installs(fresh VM). so no registry issues. just that silly manage my device option needs to be unchecked). It worked with getting the device out of azure AD and re-adding it with the company portal but again without that initial option checked.

Best of luck!
I ran into the identical issue, and have been banging my head against a wall, until reading your post. Thanks for sharing.
Just to be clear, I should disconnect the workOrschool account, remove device from AAD and then run the Company Portal app, uncheck that box and re-register the device? thanks - this is driving me crazy.