SCCM Client Deployment detection failing

Copper Contributor

Hello, All.  I'm using Intune with AutoPilot, and I've gotten everything working well, even HAADJ over VPN. (Thanks for the VPN support!!!)


The only problem I seem to be having at the moment is that I'm deploying the SCCM client via Intune in the User Scope, and it installs fine.  Intune recognizes that the device is now being co-managed, etc.


However, no matter what I've tried, the detection rule for the SCCM client continues to fail, marking it as a failed deployment.


I've tried MSI using the Product GUID, detecting the ccmexec.exe with Version, a custom detection rule that looks for various files/folders/registry keys, but nothing will identify the deployment of the client as successful. 


The client is deployed as a Win32 app.  The Windows version is 1909.


I've reviewed the Intune Management Extension logs, and other than saying that the detection rule failed, I don't see anything else helpful.


Any ideas would be appreciated.

10 Replies

@relRGB Hi, I'm struggeling with the same problem but I am not even that far I think.

I receive receive errors regarding AAD token request failed when I want to install using Winapp32.


May I ask which method and command line you are using?





Hi, we had the same issue. We´re using an regkey as detection. I´ve attached a PDF how we do it (german).


Hope that helps.


Update: cant upload files. I will send both of you an link.



@Matthias_Hei I got the command line from the SCCM Console.


Go to Administration/Cloud Services/Co-management

Right-click on CoMgmtSettingsProd

Choose Properties


On the Enablement tab, you can see at the bottom of the screen the command line arguments to use to install.


@relRGB Try to use a key under Registry HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\CCMSetup
Other keys like CCM are not yet available at the moment the detection is performed, they`re added short after that.

@Peter Klapwijk 


Did you ever get this working. I am still having the same issue. It installs, but indicates failure on every detection type.

Did you figure it out. I am still having the issue. The client installs, but always detected as failed.
I found another blog that explained why the detection methods dont work. I run ccmsetup /noservice and it works great.
best response confirmed by mobazzari (Microsoft)

@Ronald Lawrimore For reference for other users who read this, here is a post with that information

Hi Peter, Is that link dead now? It doesn't work and I'd love to know what it says about using /noservice.
1 best response

Accepted Solutions
best response confirmed by mobazzari (Microsoft)