Tech Community Live: Endpoint Manager edition
Jul 21 2022, 08:00 AM - 12:00 PM (PDT)

Resuming Quality updates in Intune

Frequent Contributor

Recently we have paused a quality update for Windows 10 because of an issue with one of our application. After that issue was solved we hit the resume button in the update ring in Intune.

I was expecting that as soon we resumed the quality updates, the pause period would be disabled on the devices, but we noticed on the devices that updates are resuming after the default period of 35 days and not immediately.

Is this normal behaviour?

22 Replies

@Ronald Meer I'm seeing the same behavior when pausing Feature updates, I assumed it would resume immediately but it hasn't.

@Ronald MeerI´m having the same issue.
I have paused from the Intune Portal and clicked on resume, but the machines are still paused.

 

I´m thinking about creating a new policy.

@Dan18539 

After you resume updates the updates will continue after the default period of 35 days.

This makes the Resume button functionally useless. If not resumed, it automatically resumes after 35 days. If resumed, it waits till day 35 to resume.

Is this working as expected right now?

@thedrum808a 

 

If you do not hit the resume button. Updates will be paused indefinitely.

How do 35 days count? Since the day you paused it, or 35 days from the time you resume it?
This is an old post but I'm having the exact same problem. We paused updates to stop a buggy Update from Microsoft coming down and breaking our VPN, and now resuming it we find all the devices stuck and refusing to update because it's 'paused by the organisation' even though we've resumed updates in the ring. So we are now stuck with devices out of date and unable to update. Where was the thinking within Microsoft that thought that was a good idea? When resumed, they should resume not continue to be paused for over a month. Is there a work around or a way to make updates resume?

Hi

Could you take a look at these settings
HKLM\SOFTWARE\Microsoft\WindowsUpdate\UpdatePolicy\Settings
Maybe changing them to zero if these settings are still configure to 1 or 2? and if that ain't working

 

I would check out this key... as it notes the start time... maybe removing that key ?

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PolicyManager\current\device\Update

I'm having similar issues after resuming the updates in Intune, but only my Hybrid Azure AD joined devices. Our Azure AD joined devices are not exhibiting this behaviour. I am wondering if this is a hang up of old AD GPOs still on the device.

@Rudy_Ooms_MVP Hi.  That fix does actually work thank you, although I deleted the three entries instead of changing them because they weren't present on a few machines which didn't have this issue.  The problem 'fixing' this is the large number of devices and the spread of them remotely.  I'm tempted to try and push this reg change out via intune but I'm cautious of unknown consequences.

 

I just cant believe that without any prompts or warnings within intune, Microsoft has decided this is the behaviour for updates being paused and restarted. 

Hi,

Just curious but which of the registry keys did you deleted? Sounds like a proactive remediation to me...
IF those keys are found exit 1 --> remediation delete those keys with powershell and exit 0

Yes so on that path I deleted these
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PolicyManager\current\device\Update

PauseQualityUpdatesStartTime
PauseQualityUpdatesStartTime_ProviderSet
PauseQuanityUpdatesStartTime_WinningProvider

After doing that, hitting the 'Check updates' button goes off and downloads/installs the updates as normal. This has worked manually on about 5-6 workstations so far. Other than in one case so far I didn't have to restart the machine either, but that may have been a separate issue. Its not practical to do this remotely on all the other machines.

We are in a hybrid environment.

Hi.. I guess I got some content for a new blog :p ... When looking at those registry keys... were there values in it after you resumed the updates or were they empty?
Just checking now on one device and they don't seem to have come back.

When you first pauze those updates it will add a date in the PauseQualityUpdatesStartTime value . I am wondering if those are also empty or still configured.

We paused and resumed the same day. Paused because of a Microsoft bug that broke vpn for our staff with Jan update. We then worked out a work around so resumed it a few hours later. Not all of the devices got hit with the pause, just most of them. Those that have an issue have those three reg entries, other devices without the problem don't have them. They don't have different values, they don't exist at all. There's a bug there somewhere that doesn't take that date away 'On resume' in intune, or at least not promptly enough. It's been nearly 10 days since resume and it's still on those devices.

Hi just wondering but on how many devices do you need to do this? You could use pro active remedaitiaons to check out the key... and if those exist... just delete them like you did?

Still need it test it more but...


Windows Updates not Resuming after Pausing WUfB Rings Fix (call4cloud.nl)

 

It's around 130 and they are 99% off premises.



Hi

Just read your blog based on this issue and answer. Could you tell me where in intune you are putting the detect and remediation scripts? What type of intune configuration is it?