Policy Sets some apps not showing for selecting


Ive been setting up some apps for a test in MEM and am trying to assign each one to a policy set. Office 365 was first and that worked but then I set up Microsoft Edge and that doesnt show, next a web link to Onedrive that does show and now a MS store app for Citrix Workspace and that doesnt.

Im not sure why some show and some dont - am I missing something? Ive tried having teh apps assigned to a group (same group the policy is assigned to) and also not but no change.


Hopefully someone can enlighten me as to where im going wrong or if there are limitations

2 Replies
best response confirmed by PhilRiceUoS (Contributor)

Here is the limitations that we have in policy sets at the moment, that seems to fit with your expirence. 

The following app types are currently supported by policy sets:

  • iOS/iPadOS store app
  • iOS/iPadOS line-of-business app
  • Managed iOS/iPadOS line-of-business app
  • Android store app
  • Android line-of-business app
  • Managed Android line-of-business app
  • Microsoft 365 Apps (Windows 10)
  • Web link
  • Built-in iOS/iPadOS app
  • Built-in Android app

@perlarsen1975  Thanks Per , explains things nicely.
I guess currently it might be simpler to not reply on policy sets for the app assignment part as a mixed solution seems more confusing. Just use them for the areas that they cover completely and have a groups based approach for apps.

Do you know if there are plans to extend what apps are included in policy sets to cover all the different types? I can see them being very useful when that is possible. Im surprised Microsoft Edge is not supported already.