Package size get extremely larger than the original MSI file after preparing using IntuneWinAppUtil

Iron Contributor

Hi Folks, 


I've been trying to push Java (JRE) package via EndPoint Manager to WIn10 devices but the file size gets extremely large (2.9 GB) than its original MSI file which is just 80MB. And Microsoft EndPoint Manager doesn't create the app and the end (stating "Your app is not ready yet. If app content is uploading, wait for it to finish. If app content is not uploading, try creating the app again")




How I got the MSI: 

In a test Machine, I simply opened up the Java JRE exe (jre-8u331-windows-x64.exe) and kept it open/untouched which apparently produces the source files in to the location "C:\Users\UserName\AppData\LocalLow\Oracle\Java\jre1.8.0_331" temporarily. Grabbed the .msi file from there (there were no other files in there) and used it as the source to package a ".intunewin" file using the IntuneWinAppUtility. 


I've noticed the same in various other applications and wondering if anyone has seen/sorted this ? Really appreciate any inputs!! 


Thanks heaps

6 Replies
Which version are you using from the intunewin util? what happens when you extract the contents of that file? so you can be `100% sure that there isn't anything weird in it

@Manoj Karunarathne 

Did you copy the MSI into a folder for the source?  The intunewin app grabs anything in the folder you specify as the source folder, it sounds like the source location probably had more files in it.

@andrew1810  as he told there were no aditional files in the source folder … it shouldnt be added to the intunewinfile… thats why i asked to extract it in the first response to be sure :)… so waiting for the repsonses

Thanks @Rudy_Ooms_MVP , @andrew1810 for the prompt response ! 

I only had the .msi file in the source folder that was copied across from elsewhere but yes, the folder only contained that single file. 





Version - I just downloaded the latest from Github which says "updated 10 months ago"(




best response confirmed by Manoj Karunarathne (Iron Contributor)
Update - I still couldn't figure out the root cause however, I just tried the same in a separate device after downloading the tool again from the GitHub location specified above (with newly created source and output folders) and voila ! it went smoothly (finished up in a few seconds while the output file size is similar to the source file).

Thanks again for your prompt responses !

@Manoj Karunarathne this also randomly happened to me.


15 MB msi file -> 500MB intunewin file


Tried again, and it got to the expected 15 MB. Seems like a random bug.