SOLVED

Outlook for Android on Work Profile won't open URL's

New Contributor

Hey all,

 

I've rolled out Outlook for Android using InTune and Android Work Profiles and it installs and works well apart from the user not being able to click on links in emails and have them open in the default browser.

 

I haven't made or can even find any policies that would restrict this behaviour. 

 

If the user installs Outlook for Android from the consumer Playstore then URL's open fine as expected.

 

Anyone have any ideas?

 

Cheers, Tim

9 Replies
best response confirmed by Tim Welch (New Contributor)
Solution

@Tim Welch Did you publish a browser (preferably as required app) in the work profile? If you do not make one available in the work profile no browser is installed which is probably the reason why the URL are not working.

 

Thanks,

Bart

@bthomas  - arh, that makes perfect sense now that I think about it. Siloing data completely between personal and work.

@bthomas 

That sounds right... but how do I do that? I'm having the same issue as the OP. 

@jc45or What is your problem exactely, can you eloborate some more?

Forgive the change in name. It sounds like I'm having the same issue you had. I have several Gmail accounts under personal that I can click links in emails and it takes me to the page. However, I just added a new email under 'work profile' and it doesn't let me click on any of the links in emails.
Do you have a browser installed in the Work Profile? Depending on the launcher that you are using, you should have a seperate 'tab' that shows all the Personal and Work apps. If there is no browser available in the Work tab, then you'll need to push a browser to the device is a required app.
Any idea where to go to set up the browser selection for the work profile? I'm using the Gmail app on my Android and I use Chrome.
Are your Gmail app and Chrome installed in the Work Profile? They should have a suitecase badge on the icon of the app.
To add apps to the Work Profile, check this MS doc: https://docs.microsoft.com/en-us/mem/intune/apps/apps-add-android-for-work
Normally when you have a browser installed in your workprofile it should be working... Are those emailaccounts configured in the outlook app? Are there any app protection policies configured which could stop these kind of actions?