Multi-App Kiosk Issues (Autologin not working, black screen after login, app not pinning)

Copper Contributor

We have deployed a kiosk profile for about two years with no issues. This profile is configured within Intune using the canned Kiosk template. It is a multi-app kiosk that allows one of our in-house applications (WPF) as well as Microsoft Remote Desktop Client and UPS Worldship. The in-house app auto-launches and is the only app pinned to the start layout. Again, this has worked flawlessly for 2 years.

Now, we are looking to deploy a new version of that in-house application (.NET Maui, as we are using this application on Androids as well), but it has been quite a struggle. The profile mimics the former one, except in place of the WPF application, we are allowing the newer .NET Maui application. In the first few deployments, we only had a single issue which is that the application tile did not pin to the kiosk Windows 11 start layout. Now, we are experiencing multiple issues which are:

1.) Auto-login not working even though the profile is being created and the configuration for that is set correctly. This is happening on every deployment now.
2.) Black screen after login. This is happening more and more, but has not happened on every deployment.

3.) The tile will not pin to the start menu, no matter what layout config I have tried. Even if I do not push a custom layout and allow the configuration to handle this, it does not set any tiles. I even tried pushing an OMA-URI to pin the tile, and this worked on every profile (admin and standard) EXCEPT the kiosk profile.

I should mention that the application works in a standard user profile on the devices in question.  This has been quite the pain and any help would be much appreciated. I can provide whatever additional details which would help.
Config below:


1 Reply

I don't know if you came across this documentation Multi-App Kiosk Issues (Autologin not working, black screen after login, app not pinning) - Microsof...
but multi-app kiosk is only supported on Windows 10. It's not supported on Windows 11 and there is some troubleshooting steps they may help if you have the issue with windows 10 devices too.