Managed Home Screen Dedicated Devices in Multi-app Kiosk Mode_No Virtual Home Button

%3CLINGO-SUB%20id%3D%22lingo-sub-1808116%22%20slang%3D%22en-US%22%3ERe%3A%20Managed%20Home%20Screen%20Dedicated%20Devices%20in%20Multi-app%20Kiosk%20Mode_No%20Virtual%20Home%20Button%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1808116%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F727559%22%20target%3D%22_blank%22%3E%40techtest%3C%2FA%3EI'm%20facing%20the%20same%20issue.%20I%20was%20able%20to%20use%20virtual%20home%20button%20for%20some%20time%2C%20but%20now%20there%20is%20now%20way%20to%20grant%20the%20overlay%20permission%20to%20ManagedHome.%20Are%20you%20been%20able%20to%20solve%20this%20problem%3F%20Could%20you%20please%20give%20me%20some%20advice%3F%3C%2FP%3E%3CP%3EThanks%20a%20lot.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1809113%22%20slang%3D%22en-US%22%3ERe%3A%20Managed%20Home%20Screen%20Dedicated%20Devices%20in%20Multi-app%20Kiosk%20Mode_No%20Virtual%20Home%20Button%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1809113%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F842161%22%20target%3D%22_blank%22%3E%40AlessandroFabiani%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20issue%20ended%20up%20being%20the%20'Notification%20Windows'%20setting%20in%20the%20Device%20Configuration%20Profile.%20You%20have%20to%20turn%20that%20to%20'Not%20Configured'%2C%20and%20that%20will%20resolve%20the%20issue%20of%20the%20Overlay%20Permission%20alert%20(you'll%20still%20get%20this%20alert%20one%20time%20when%20the%20scanner%20is%20first%20setup%2C%20but%20after%20that%20it%20will%20go%20away)%2C%20and%20it%20also%20resolves%20the%20issue%20of%20the%20Virtual%20Home%20Button%20not%20appearing%20if%20you%20have%20that%20setting%20turned%20on.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20hope%20that%20helps.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1520085%22%20slang%3D%22en-US%22%3EManaged%20Home%20Screen%20Dedicated%20Devices%20in%20Multi-app%20Kiosk%20Mode_No%20Virtual%20Home%20Button%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1520085%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20All%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20testing%20out%20the%20Managed%20Home%20Screen%20with%202-3%20apps%20on%20dedicated%20devices%20in%20multi-app%20kiosk%20mode.%20I%20tested%20them%20on%20a%20Zebra%20TC77%2C%20which%20has%20physical%20buttons%20below%20the%20display%2C%20and%20all%20worked%20as%20expected.%20However%2C%20when%20testing%20on%20a%20Zebra%20TC57%2C%20the%20Home%20Button%20and%20Recent%20Apps%20buttons%20disappear%20shortly%20after%20rebooting%20the%20device%2C%20or%20immediately%20after%20opening%20any%20of%20the%202-3%20apps.%20I've%20spoken%20with%20Microsoft%20and%20this%20is%20by%20design%2C%20which%20makes%20sense.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHowever%2C%20both%20the%20Device%20Configuration%20Profile%20and%20Managed%20Home%20Screen%20App%20Configuration%20Profile%20offers%20settings%20for%20a%20Virtual%20Home%20Button.%20I%20have%20attempted%20to%20enable%20this%20as%20both%20a%20%22swipe-up%22%20and%20a%20%22floating%22%20virtual%20home%20button%2C%20in%20both%20the%20Device%20Config%20Profile%20and%20the%20App%20Config%20Profile%2C%20and%20the%20Virtual%20Home%20Button%20does%20not%20appear.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20believe%20the%20issue%20is%20related%20to%20the%20Overlay%20Permissions%2C%20because%20when%20I%20have%20the%20Virtual%20Home%20Button%20enabled%2C%20the%20Managed%20Home%20Screen%20Settings%20shows%20a%20red%20notification%20which%20wants%20me%20to%20grant%20Overlay%20Permissions%20for%20the%20app.%20Those%20permissions%20have%20already%20been%20granted.%20When%20I%20turn%20off%20the%20Virtual%20Home%20Button%2C%20that%20notification%20goes%20away.%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22techtest_1-1595436218158.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F207169iC7D92FEBA506F77A%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22techtest_1-1595436218158.png%22%20alt%3D%22techtest_1-1595436218158.png%22%20%2F%3E%3C%2FSPAN%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22techtest_2-1595436240737.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F207171i582542F66243FE44%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22techtest_2-1595436240737.png%22%20alt%3D%22techtest_2-1595436240737.png%22%20%2F%3E%3C%2FSPAN%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22techtest_0-1595436196765.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F207168iB51F9D608A106C72%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22techtest_0-1595436196765.png%22%20alt%3D%22techtest_0-1595436196765.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDoes%20anyone%20have%20any%20ideas%20on%20a%20solution%20for%20this%20issue%3F%20I%20do%20have%20an%20open%20ticket%20with%20Microsoft%20and%20will%20update%20this%20post%20if%20we%20reach%20a%20resolution.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E*Resolved*%20-%26nbsp%3B%3CSPAN%3EThe%20issue%20ended%20up%20being%20the%20'Notification%20Windows'%20setting%20in%20the%20Device%20Configuration%20Profile.%20You%20have%20to%20turn%20that%20to%20'Not%20Configured'%2C%20and%20that%20will%20resolve%20the%20issue%20of%20the%20Overlay%20Permission%20alert%20(you'll%20still%20get%20this%20alert%20one%20time%20when%20the%20scanner%20is%20first%20setup%2C%20but%20after%20that%20it%20will%20go%20away)%2C%20and%20it%20also%20resolves%20the%20issue%20of%20the%20Virtual%20Home%20Button%20not%20appearing%20if%20you%20have%20that%20setting%20turned%20on.%3C%2FSPAN%3E%3C%2FP%3E%3CDIV%20class%3D%22mceNonEditable%20lia-copypaste-placeholder%22%3E%26nbsp%3B%3C%2FDIV%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1520085%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EIntune%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EManaged%20Home%20Screen%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EManaged%20Home%20Screen%20app%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Occasional Contributor

Hi All,

 

I'm testing out the Managed Home Screen with 2-3 apps on dedicated devices in multi-app kiosk mode. I tested them on a Zebra TC77, which has physical buttons below the display, and all worked as expected. However, when testing on a Zebra TC57, the Home Button and Recent Apps buttons disappear shortly after rebooting the device, or immediately after opening any of the 2-3 apps. I've spoken with Microsoft and this is by design, which makes sense.

 

However, both the Device Configuration Profile and Managed Home Screen App Configuration Profile offers settings for a Virtual Home Button. I have attempted to enable this as both a "swipe-up" and a "floating" virtual home button, in both the Device Config Profile and the App Config Profile, and the Virtual Home Button does not appear.

 

I believe the issue is related to the Overlay Permissions, because when I have the Virtual Home Button enabled, the Managed Home Screen Settings shows a red notification which wants me to grant Overlay Permissions for the app. Those permissions have already been granted. When I turn off the Virtual Home Button, that notification goes away.

techtest_1-1595436218158.pngtechtest_2-1595436240737.pngtechtest_0-1595436196765.png

 

Does anyone have any ideas on a solution for this issue? I do have an open ticket with Microsoft and will update this post if we reach a resolution.

 

*Resolved* - The issue ended up being the 'Notification Windows' setting in the Device Configuration Profile. You have to turn that to 'Not Configured', and that will resolve the issue of the Overlay Permission alert (you'll still get this alert one time when the scanner is first setup, but after that it will go away), and it also resolves the issue of the Virtual Home Button not appearing if you have that setting turned on.

 

 

2 Replies

@techtestI'm facing the same issue. I was able to use virtual home button for some time, but now there is now way to grant the overlay permission to ManagedHome. Are you been able to solve this problem? Could you please give me some advice?

Thanks a lot.

@AlessandroFabiani 

 

The issue ended up being the 'Notification Windows' setting in the Device Configuration Profile. You have to turn that to 'Not Configured', and that will resolve the issue of the Overlay Permission alert (you'll still get this alert one time when the scanner is first setup, but after that it will go away), and it also resolves the issue of the Virtual Home Button not appearing if you have that setting turned on.

 

I hope that helps.