Managed Home Screen Android Kiosk issue after update Galaxy A32

New Contributor

We have 100+ Samsung A32 phones in kiosk-mode with the managed-home screen as default launcher.

After the latest update from de managed-home screen app. 2.2.0.73054, the home-screen starts flickering without icons. The same after reboot. Phones are unusable. If you remove the sim (temporarily) then the managed-home screen app will load with icons. After you place the sim back, the home-screen starts flickering again without icons. If you change the home-screen to the default samsung launcher there is no issue. So it seems to be related to the latest version of the home-screen app from Microsoft.

Somebody else experiencing these issues? I had 2 android-system updates waiting. But updating did not resolve this issue. I have disabled app-updates for now to 

9 Replies
We got exact the same problem. I still have to investigate more.

As a workaround I also disabled app updates for the working devices. Hopefully the policy will arrive at time.

Did you already staged a ticket at Microsoft Support?

We got version 2.2.0.73421

I changed the setting 'Custom app layout' to 'Non configured' and now I can see tiles again. Not in the correct order, but they are there.

HilbertHofsteenge_0-1637251665145.png

 




@pengels 

@Hilbert Hofsteenge It worked for my 100 Nokia 5.6 smartphones.

@Microsoft you have to de better, it is a disaster when 100+ smartphones stop working because of a update.

 

Thanks to Hilbert

 

Klaus

@Hilbert Hofsteenge 

I tried your solution and it works for me. The problem is I still can't remote lock or restart the phone from Intune. It keeps saying it's ''Pending''.

 

Did you manage to solve this? Or do you not have this issue?

Great to hear the workaround worked for you.

I don't have any other problems with the Android devices at the moment, only the Home Screen in combination with the custom grid layout.

The latest update probably fixed it. 2.2.0.73421.
I added the "Phone" permissions to the Managed Home Screen app for the 73054 version. This fixed the problem. I added these permissions with an app configuration for this app in endpoint.

what do you mean with "phone" permissions? You added the phone app to the home screen grid layout?

@Hilbert Hofsteenge 

I added the phone permissions to the Managed Home Screen app. The screen seemed to get stuck when the Managed Home Screen app didn't have these permissions. 

Screenshot 2021-11-23 173823.png

Hmm OK... how did you find this was the issue?

I reported a ticket at Microsoft Support. Hopefully the got a proper solution for this issue