iPhone 12 DEP iOS 14.2.1 fails to download

Occasional Contributor

Hello!

We have 2 iPhone 12 that are having issues downloading the latest iOS 14.2.1 through Settings - Software Update.

We just get an error message stating: "An error occured when iOS 14.2.1 was being downloaded". We tried restarting the devices, using other Wi-Fi and using mobile data. We successfully updated one of the devices through iTunes.. is this a known error for iOS 14.2.1? I think that it might be related to this update just being released for iPhone 12 models. 

9 Replies
Funnily enough, I've been struggling with this myself over the last few days - so it's not just you
Really strange. We have a general update policy for all our iPhones to "Install iOS/iPadOS Latest update". And i have tried creating a separate policy and group for just our iPhone 12 models and also to specifically "Install iOS/iPadOS 14.2.1". But the same message appears.

And one more thing i noticed is that the iPhone 12 model is recognized as just "iPhone" as model in both Endpoint Manager and the Company Portal app..

@TomHolm We have noticed the same.

the iphone 12 is indeed mentioned as just iPhone.

 

also i have two variants of the issue. the iphone 12 devices that were already on 14.2 wont update to 14.2.1 with the notification that they fail to download.

 

i had one new iphone 12 that was still on 14.1 at the time 14.2.1 was released. and that one constantly started the update, but when it was time to install, it returned to the screen showing there was an update availible an i could click download and install again. this kept on going for a day and then it installed the 14.2.1 update. 

 

i have checked the intune logging on the iphone 12 with the error, using this but the logging does not show anything usefull. at least not to me

 

We have the same problem with 2 new iPhone 12 models.
Yeah, the issue is still happening. Wonder if it will resolve itself when the next iOS update is released.

Use iTunes, if you really need the update so badly.

That is the only solution that worked for me.

 

Yeah, iTunes works. But not everyone has the ability of updating through iTunes. Hoping they will resolve this when Apple release a major release that includes all models. But i guess the device is quite new still so everything can't be working right out of the box.

@TomHolm Yup, same here, phone restored and management profile all loaded ok, but "Software update failed" 14.2.1. 

They seem to have silently fixed this issue. Several of our devices is now updating as it should be. Maybe Apple and Microsoft has deployed an fix for it :)