Intune Win32 apps error 0x80070002

Copper Contributor



For my internship i've been trying to deploy win32 apps in intune, i followed the tutorial on Microsoft Docs: My system gives me a pop up that installation has started but after en couple seconds returns with a "failed pop-up" when i go into inune i get the error 0x80070002 and sometimes Error code: 0x0 i tried googling these but i cant seem to find anything intune related. 

Can anybody point me out what the errors mean?


7 Replies

@bjornmertens Hi Normally 0x80070002 = "The system cannot find the file specified." Check that your install command line is Correct and not misspelled and that the files are in the Win32App Package..


@Jörgen Nilsson hi, i tried again wit a .msi version of 7zip (to try it out). That works without problem and is installed in the background. However with an .exe i now got it working sort of, the install command was indeed not correct. But it does not install in the  background, i just get to see the setup screen to install 7zip manually. I tried /s, /quite, /silent, /s is there another parameter to install the .exe silently?



best response confirmed by bjornmertens (Copper Contributor)

Hi @bjornmertens,

see the 7-Zip FAQ for this info:

How can I install 7-Zip in silent mode?

For exe installer: Use the "/S" parameter to do a silent installation and the /D="C:\Program Files\7-Zip" parameter to specify the "output directory". These options are case-sensitive.

For msi installer: Use the /q INSTALLDIR="C:\Program Files\7-Zip" parameters.




@Oliver Kieselbach 


Thanks you for the post! The /S mode works with 7zip. Altough i found out that not every installer works with the /S, /s, .... But i guess that most of the sofwtware will list it on there site.


@bjornmertens definitely correct that different switches work for different apps/developers. They need to include support for those when packaging.


To fix the error manually, it will be necessary to remove all of the files partially downloaded, and try again to update your Windows files.

1. On the Windows desktop, press Start, and when the menu opens up,

2. Press Run, and input the following command “services.msc”

3. In the Run box, type "services.msc", and press "Enter".

4. This will open the "Local Services" window.

5. In the Local Services window find the name “Automatic Updates” and right click.

6. On right click, scroll down and press “Stop”. This will cause the Automatic Updates to pause to correct the situation. Do not close the Local Services window.

At this point you can go to the "Software Distribution" folder and delete its contents, or give the folder another name. It is advised that you just rename the folder,

7. To do this go to the Windows desktop and press “Start” then press “Run” when the menu opens.

8. Input the “cmd” command into Run, and the computer will take you to the DOS prompt.

9. At the DOS prompt type in this command “cd %windir%” (without the quotes), and press Enter.

10. You should now be in the Windows directory.

11. At the Windows directory, input “ren SoftwareDistribution SoftDisTemp” and hit "Enter". This will rename the Software Distribution folder to the new name of SoftDisTemp.

12. Type "Exit" and hit "Enter" to close the DOS window.

13. Now go to the "Local Services" window and right click "Automatic Updates" to restart it.

14. Try updating Windows files again.


Received this error trying to add PC/laptop to Azure. Did not have Windows 10 Pro license. I was still on Windows 10 Home. Upgraded to Pro and got joined to Azure Ad (Intune).