Intune White Glove and Office 365 Deployment

Copper Contributor

@Michael Niehaus Is it possible for Office 365 to be deployed during the technician portion of White Glove as the App Type "Office 365 ProPlus Suite (Windows 10)" as opposed to a Win32 or LOB app? I have it set to be targeted to the device and required for all Autopilot devices. When I run through autopilot, it quickly skips past the app portion and then lets me reseal without installing anything. After the user logs in, the app does eventually install but our hope is to have install prior to user set up.


(As an aside, white glove did not work at all until I created slip-streamed 1903 media with all of the latest updates from the Microsoft catalog)

23 Replies

Yes we have Office deploying in white glove when set to Windows 10. What we are seeing though is that the number of apps deployed is random. Sometimes we are getting the 9 we published and other times getting 3 or 4.

Also we have noticed that the device will restart before the enrolment finishes and reseals. Sometimes it will complete the enrolment to reseal and other times it goes to a user login prompt. Seems that selecting the update ring to semi annual stops this reboot.

Sorry to change the subject also but have you seen this “issue” and what version of Windows are you running ?




I haven't seen any devices restart during enrollment at this point but I have only tested deploying Office and a single Win32 app. Perhaps one of your apps is requesting a reboot or another is seeing a pending reboot and going through with the reboot depending on the order they are getting installed.


I hadn't thought of changing the Office update ring to see if the behavior would change. We are using Monthly-Targeted but I am going to try it with Semi-Annual now. Are you using Configuration Designer or Enter XML data for the Office install Settings format?


The Windows 10 1903 version that gets installed with our slip-streamed media is 18362.175

Thanks. I am using the MCT with 18362.30 so I will try the newer version.

For Office I just selected the Windows 10 deployment and selected the Apps with no additional XML. We are using the latest version on monthly targeted on the office install. I can send you screen shots if you need tomorrow when I am back in.

@Darren_Bradley  I just realized on my new attempt with the Semi-Annual Office update ring that neither my Office app or Win32 app are installing during white glove. I just get the green reseal screen with elapsed time of 0 h 0 min. So, for us, nothing is installing prior to user setup.


EDIT: If I look at Managed Apps for the device, it shows that my other app did install (must have been so fast, it did't register), but Office failed with Error code: 0x0


It sounds like our Office app was set up the same as yours is. No XML, just chosen apps, latest version of Monthly targeted. (Now Semi-Annual) 

Have you got the apps assigned to the autopilot devices ?

@Darren_Bradley Yes, and I realize the win32 app did install (post edited above). It is just Office failing at this point with the 0x0 error code.

Maybe set the ESP to install the two apps and block access until it does ? Also are you able to install Office via the company portal if you progress with the basic enrolment. ? Reason I ask is that we have seen the Office deployment come from various officecdn servers and initially had to allow access to them from the corporate network for it to work. Or try it from a “dirty” connection ?

@Darren_Bradley For the first time, I let the green reseal screen sit for about 10 minutes after white glove. I refreshed the Managed apps in Intune and saw the status of the Office install go from an error to Installed after a few minutes. I did a Shift+F10 to get a command prompt and verified that the Office installation was in Program Files. So I am not sure if resealing right away and logging in interrupted the installation somehow on my previous attempts or if changing the Office update channels back and forth did something. 

I am doing it again now and am not going to wait at the reseal screen to see if I can re-create the previous behavior.


To answer your question, I haven't had any problems installing Office from Company portal or during user setup portion of Autopilot.

Just to note. I often find in intune it does not report it installed until the user starts enrolling. But doing the shift F10 on re seal does show it in the control panel under programs.

After running through the process again, I can confirm that my apps did not install prior to the reseal screen appearing. So reseal is coming up before the apps are completely installed and if I reseal right away, the laptop shuts down and doesn't complete the installations until it is powered back up and the process is continued. I would expect the behavior to be to not let a machine reseal and shutdown until the white glove apps are installed. This is not happening in our case.


If I leave the device on the green reseal screen for 10-15 minutes, the apps install in the background. Or if I continue the user process immediately, the apps install during, or sometimes long after, the user OOBE screens have been gone through.


The timeline I saw this last time was:

2:08 pm white glove finished with no apps installed.

2:09 pm Resealed, booted up and continued with user OOBE

2:18 pm Intune console shows "App installation completed" while User OOBE was still at the "Connecting to your network" phase.


I did have my machine reboot once this round during the white glove portion which I had not seen before.

As you suggested, I set the ESP to install the required apps and block access until it does. Same result, green reseal screen indicating that white glove is complete but the apps are still installing in the background. I can watch the progress of the installs with a Shift+F10 command prompt and in appwiz.cpl.

@Roger PlattHow have you got the assignments set for the Apps ?



@Darren_Bradley They are assigned as Required and includes our "All Autopilot Devices" group which the target machine is a member of. The group has dynamic membership based on it being an Autopilot device with the membership rule: (device.devicePhysicalIDs -any _ -contains "[ZTDId]")

We are seeing this a lot just lately. Machines that we enrolled last week were reporting the correct number of apps to install and then other machines don't. They still seem to reseal ok , but its all very random

@Darren_Bradley are you guys using Hybrid AD join? I think that is causing the reboot (in my scenario) and once that happens it seems to just stop the White Glove and says its done but does continue to check in in the background and apply policies and Apps if you sit on that completion screen. I can also reseal, power on and just let it sit at the OOBE and that seems to work too. Just curious if this is happening to AAD joined or just Hybrid AD.

@Andrew Allston 


We are just using Azure Joined Machines. We found once we selected Semi Annual channel on the updates the reboots stopped , although the update policy fails in Intune due to 1903 not having semi annual. Still not sure why it reboots or what causing it , but we needed to get around it quick as we are in pilot 

Hey thanks! I really didnt even notice that the first post i responded to was also by you. Thank again for the info. I missed the fact about 1903 not having Semi Annual... whats up with that? 🤨 But that fixes another issue for me! Thanks a bunch :thumbs_up:

@Andrew Allston 


Yes we have had our fair share of issues that for sure and a lot of Gotchas. We are also using patching the machines now with 18362.207 as that fixes the offline apps issue within the store. 18362.30 only seems to work with offline apps. 


I did find this on Semi Annual but still not 100% on it , all I know is when we select that it works .. Autopilot will pull down updates as they are needed

@Darren_Bradley  Did you ever solve this issue? We are testing White Glove with 1909 and trying to install Office ProPlus we see the same behavior. The green screen with the reseal button comes up very quickly but the installation is not done/finished.

When we let it sit for about 20 minutes before resealing the installation is finished. When using the shift-F10 and then the explorer and installed programs we can see all the sources and the ProPlus installation.