Intune Enrollment via GPO User eXperience

%3CLINGO-SUB%20id%3D%22lingo-sub-815027%22%20slang%3D%22en-US%22%3EIntune%20Enrollment%20via%20GPO%20User%20eXperience%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-815027%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20All%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20successfully%20setup%20Hybrid%20Azure%20AD%20Join%20and%20I%20have%20implemented%20Auto-enrollment%20into%20Intune%20via%20GPO.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHowever%2C%20on%20my%20test%20user(s)%20I'm%20still%20getting%20MDM%20status%20%3D%20None.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECan%20anyone%20tell%20me%20what%20the%20User%20eXperience%20should%20be%20for%20this%20type%20of%20Intune%20Enrollment%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDoes%20the%20User%20get%20prompted%20to%20sign%20in%20or%20anything%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EInfo%20appreciated%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-815027%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EIntune%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMobile%20Device%20Management%20(MDM)%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-838651%22%20slang%3D%22en-US%22%3ERe%3A%20Intune%20Enrollment%20via%20GPO%20User%20eXperience%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-838651%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F131657%22%20target%3D%22_blank%22%3E%40Stuart%20King%3C%2FA%3E%26nbsp%3BCould%20you%20please%20share%20some%20more%20information%20about%20your%20setup%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3COL%3E%3CLI%3EWhat%20GPO%20settings%20did%20you%20apply%3F%3C%2FLI%3E%3CLI%3EIs%20this%20not%20working%20for%20any%20machines%20that's%20joined%20to%20local%20AD%3F%3C%2FLI%3E%3C%2FOL%3E%3CP%3EWhen%20you%20set%20the%20gpo%20for%20device%20enrollment%2C%20the%20end%20machine%20will%20need%20to%20reboot%20and%20login.%20Once%20logged%20in%2C%20if%20you%20go%20to%20windows%20settings%2C%20you%20should%20see%20an%20info%20button%20on%20the%20work%20or%20school%20account%20which%20confirms%20that%20your%20machine%20is%20joined%20to%20Hybrid%20Azure%20AD.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnother%20way%20to%20check%20is%20to%20run%20the%20command%20dsregcmd%20%2Fstatus.%3C%2FP%3E%3CP%3EMore%20troubleshooting%20steps%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Factive-directory%2Fdevices%2Ftroubleshoot-hybrid-join-windows-current%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Factive-directory%2Fdevices%2Ftroubleshoot-hybrid-join-windows-current%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-842982%22%20slang%3D%22en-US%22%3ERe%3A%20Intune%20Enrollment%20via%20GPO%20User%20eXperience%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-842982%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F50314%22%20target%3D%22_blank%22%3E%40Ambarish%20RH%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EYes%2C%20the%20machines%20are%20showing%20as%20Hybrid%20Azure%20AD%20Join%20but%20not%20as%20enrolled%20in%20Intune.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EStuart%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-844453%22%20slang%3D%22en-US%22%3ERe%3A%20Intune%20Enrollment%20via%20GPO%20User%20eXperience%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-844453%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F131657%22%20target%3D%22_blank%22%3E%40Stuart%20King%3C%2FA%3E%26nbsp%3BI%20had%20similar%20issues%20with%20on%20my%20tenant%20where%20devices%20will%20show%20in%20Azure%20AD%20Devices%20as%20Hybrid%20Azure%20AD%20Join%20but%20not%20in%20All%20Devices%20and%20the%20MDM%20state%20is%20shown%20as%20none.%20The%20fix%20for%20my%20case%20was%20to%20set%202%20GPO%20policy%20settings%20(As%20per%20MS%20Support%2C%20the%20first%20device%20registration%20policy%20adds%20the%20device%20to%20Azure%20AD%20and%20MDM%20part%20enrolls%20the%20device%20to%20intune%2C%20and%20we%20need%20to%20have%20both%20to%20get%20the%20devices%20fully%20managed%20via%20intune%2FMDM)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F130765i63E720387B688EC1%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_0.png%22%20title%3D%22clipboard_image_0.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F130767iD62D46D92504F724%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_0.png%22%20title%3D%22clipboard_image_0.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20you%20do%20not%20see%20the%20policy%2C%20it%20may%20be%20because%20you%20don%E2%80%99t%20have%20the%20ADMX%20installed%20for%20Windows%2010%2C%20version%201803%20or%20version%201809.%20To%20fix%20the%20issue%2C%20follow%20these%20steps%3A%3C%2FP%3E%3COL%3E%3CLI%3EDownload%3A%3CBR%20%2F%3E1803%20--%26gt%3B%3CA%20href%3D%22https%3A%2F%2Fwww.microsoft.com%2Fen-us%2Fdownload%2Fdetails.aspx%3Fid%3D56880%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3EAdministrative%20Templates%20(.admx)%20for%20Windows%2010%20April%202018%20Update%20(1803)%3C%2FA%3Eor%3CBR%20%2F%3E1809%20--%26gt%3B%20%3CA%20href%3D%22https%3A%2F%2Fwww.microsoft.com%2Fen-us%2Fdownload%2Fdetails.aspx%3Fid%3D57576%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3EAdministrative%20Templates%20for%20Windows%2010%20October%202018%20Update%20(1809)%3C%2FA%3E.%3C%2FLI%3E%3CLI%3EInstall%20the%20package%20on%20the%20Primary%20Domain%20Controller%20(PDC).%3C%2FLI%3E%3CLI%3ENavigate%2C%20depending%20on%20the%20version%20to%20the%20folder%3A%201803%20--%26gt%3B%20%3CSTRONG%3EC%3A%5CProgram%20Files%20(x86)%5CMicrosoft%20Group%20Policy%5CWindows%2010%20April%202018%20Update%20(1803)%20v2%3C%2FSTRONG%3E%2C%20or%3CBR%20%2F%3E1809%20--%26gt%3B%20%3CSTRONG%3EC%3A%5CProgram%20Files%20(x86)%5CMicrosoft%20Group%20Policy%5CWindows%2010%20October%202018%20Update%20(1809)%20v2%3C%2FSTRONG%3E%3C%2FLI%3E%3CLI%3ECopy%20policy%20definitions%20folder%20to%20%3CSTRONG%3EC%3A%5CWindows%5CSYSVOL%5Cdomain%5CPolicies%3C%2FSTRONG%3E.%3C%2FLI%3E%3CLI%3ERestart%20the%20Primary%20Domain%20Controller%20for%20the%20policy%20to%20be%20available.%20This%20procedure%20will%20work%20for%20any%20future%20version%20as%20well.%3C%2FLI%3E%3C%2FOL%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-844480%22%20slang%3D%22en-US%22%3ERe%3A%20Intune%20Enrollment%20via%20GPO%20User%20eXperience%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-844480%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F50314%22%20target%3D%22_blank%22%3E%40Ambarish%20RH%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThat's%20very%20interesting%2C%20using%20the%202%20GPO's.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20had%20that%20setup%20already%2C%20then%20removed%20the%20Device%20Registration%20one%20as%20I%20was%20advised%20that%20this%20was%20NOT%20needed%20for%20Hybrid%20Azure%20AD%20Join%2C%20as%20all%20domain%20devices%20register%20as%20Hybrid%20Azure%20AD%20Join%20once%20AADC%20has%20been%20configured%20this%20way.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20will%20re-implement%20the%20Device%20Registration%20policy%20and%20keep%20you%20posted.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20again%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1656526%22%20slang%3D%22en-US%22%3ERe%3A%20Intune%20Enrollment%20via%20GPO%20User%20eXperience%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1656526%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F50314%22%20target%3D%22_blank%22%3E%40Ambarish%20RH%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F131657%22%20target%3D%22_blank%22%3E%40Stuart%20King%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMy%20environment%20is%20as%20follows%3A-%3C%2FP%3E%3CP%3EOn%20Premise%20AD%26nbsp%3B%3C%2FP%3E%3CP%3EHybrid%20Azure%20AD%20Joined%20devices%20using%20AD%20Connect%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20was%20also%20facing%20the%20same%20situation%20where%20the%20status%20of%20the%20MDM%20was%20%3CSTRONG%3ENone%3C%2FSTRONG%3E%20rather%20than%20%3CSTRONG%3EMicrosoft%20Intune%3C%2FSTRONG%3E%20for%20my%20Windows%2010%20devices.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAmbarish%20I%20followed%20that%20extra%20step%20to%20%3CSTRONG%3ERegister%20domain%20joined%20computers%20as%20devices%3C%2FSTRONG%3E%20and%20now%20it%20seem%20to%20work.%20I%20would%20why%20this%20setting%20is%20needed%20given%20the%20device%20is%20already%20Hybrid%20Azure%20AD%20Joined%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPreviously%20I%20did%20get%20this%20to%20work%20but%20only%20when%20the%20device%20was%20line%20of%20sight%20to%20my%20on%20premise%20AD.%20i.e.%20in%20the%20office.%26nbsp%3B%20So%20I%20thought%20that%20was%20just%20the%20limitation%20of%20auto%20enrolment.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBecause%20all%20my%20users%20are%20now%20WFH%20due%20for%20COVID%26nbsp%3BI%20will%20need%20to%20try%20this%20with%20some%20other%20devices%20but%20it%20now%20looks%20more%20positive.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1656667%22%20slang%3D%22en-US%22%3ERe%3A%20Intune%20Enrollment%20via%20GPO%20User%20eXperience%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1656667%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F131657%22%20target%3D%22_blank%22%3E%40Stuart%20King%3C%2FA%3E%26nbsp%3BI%20have%20these%20problems%20every%20time.%20what%20I%20did%20is%20to%20run%20dsregcmd%20%2Fstatus%20and%20see%20if%20the%20AzureADPRT%20value%20is%20NO.%20then%20if%20the%20value%20is%20NO%2C%20reboot%20the%20machine%20and%20login%20using%20the%20O365%20account%20UPN%20(%3CA%20href%3D%22mailto%3Asample%40contoso.com%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Esample%40contoso.com%3C%2FA%3E).%20It%20doesn't%20matter%20if%20it%20is%20the%20same%20with%20the%20on-premise%20AD%20UPN%20but%20you%20need%20to%20type%20the%20whole%20UPN%20name%20as%20login.%26nbsp%3B%20It%20will%20create%20a%20new%20profile%20and%20then%20go%20to%20work%20or%20school%20account%20and%20click%20on%20info.%20Once%20all%20the%20progress%20is%20successful%2C%20run%20the%20dsregcmd%20%2Fstatus%20command%20again%20and%20see%20if%20the%20AzureADPRT%20value%20has%20changed.%3C%2FP%3E%3CP%3ENote%3A%20do%20not%20run%20cmd%20as%20administrator%20if%20you%20are%20applying%20the%20policy%20per%20user%20basis%20not%20on%20per%20device.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAlso%20check%20the%20task%20scheduler%20of%20the%20affected%20machine.%20A%20successful%20Hybrid-joined%20device%20will%20automatically%20create%20a%20scheduled%20task.%20Also%2C%20check%20the%20event%20viewer%20for%20errors.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHope%20this%20helps.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1656704%22%20slang%3D%22en-US%22%3ERe%3A%20Intune%20Enrollment%20via%20GPO%20User%20eXperience%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1656704%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F33025%22%20target%3D%22_blank%22%3E%40Chris%20Yue%3C%2FA%3E%26nbsp%3BIt%20is%20actually%20required%20as%20part%20of%20the%20GPO%20Policy%20for%20Hybrid-joined%20devices.%20It%20should%20be%20worth%20noting%20that%20when%20configuring%20GPO%20for%20devices%2C%20you%20only%20need%20to%20change%20Computer%20Config%20policies%20and%20never%20duplicate%20the%20same%20policy%20on%20the%20User%20Config.%3C%2FP%3E%3CP%3EHere's%20a%20preview%20of%20mine.%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Manual%20Policy%20configured.jpg%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F217722i578575A6AF6A912A%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22Manual%20Policy%20configured.jpg%22%20alt%3D%22Manual%20Policy%20configured.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1656804%22%20slang%3D%22en-US%22%3ERe%3A%20Intune%20Enrollment%20via%20GPO%20User%20eXperience%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1656804%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F304952%22%20target%3D%22_blank%22%3E%40almarlibetario%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20for%20the%20tip.%3C%2FP%3E%3CP%3EOn%20the%20articles%20I%20have%20seen%2C%20I%20saw%20reference%20to%20Enable%20automatic%20MDM%20enrolment%20using%20default%20Azure%20Ad%20but%20not%20the%20device%20registration%20one.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnother%20thing%20I%20have%20noticed%20is%20the%20following.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhere%20a%20user%20picture%20has%20been%20assigned%20to%20Office%20365%2C%20which%20is%20visible%20in%20office.com%20and%20mobile%20apps%2C%20should%20this%26nbsp%3B%20appear%20on%20Windows%2010%20devices%20at%20the%20login%20screen%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20got%20this%20once%2C%20but%20since%20retiring%20the%20device%20and%20re-enrolling%20again%2C%20I%20don't%20see%20it%20anymore.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1659740%22%20slang%3D%22en-US%22%3ERe%3A%20Intune%20Enrollment%20via%20GPO%20User%20eXperience%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1659740%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F131657%22%20target%3D%22_blank%22%3E%40Stuart%20King%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3COL%3E%3CLI%3E%3CSPAN%3EVerify%20that%20the%20user%20who%20is%20going%20to%20enroll%20the%20device%20has%20a%20valid%20Intune%20license.%3C%2FSPAN%3E%3C%2FLI%3E%3CLI%3EMake%20sure%20that%20your%20auto-enrollment%20(%3CSPAN%3EMDM%20user%20scope%20to%20%22All%22)%3C%2FSPAN%3E%20settings%20are%20configured%20under%20Microsoft%20Intune%20instead%20of%26nbsp%3BMicrosoft%20Intune%20Enrollment.%3C%2FLI%3E%3CLI%3EVerify%20that%20the%20%3CEM%3EEnable%20Automatic%20MDM%20enrollment%20using%20default%20Azure%20AD%20credentials%3C%2FEM%3E%20group%20policy%20%26nbsp%3B%20(Computer%20Configuration%20%26gt%3B%20Policies%20%26gt%3B%20Administrative%20Templates%20%26gt%3B%20Windows%20Components%20%26gt%3B%20MDM)%20is%20properly%20deployed%20to%20all%20devices%20which%20should%20be%20enrolled%20into%20Intune.%3C%2FLI%3E%3CLI%3E%3CSPAN%3EVerify%20that%20Microsoft%20Intune%20should%20allow%20enrollment%20of%20Windows%20devices%20(Device%20enrollment%20restrictions%20in%20Endpoint%20Manager%20portal)%3C%2FSPAN%3E%3C%2FLI%3E%3C%2FOL%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1680681%22%20slang%3D%22en-US%22%3ERe%3A%20Intune%20Enrollment%20via%20GPO%20User%20eXperience%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1680681%22%20slang%3D%22en-US%22%3E%3CP%3EI%20recently%20had%20another%20instance%20where%20the%20%3CSTRONG%3EAzureAdPrt%20%3C%2FSTRONG%3Ewas%20NO%2C%20an%20MS%20support%20agent%20gave%20me%20the%20following%20steps%3A%3C%2FP%3E%3CP%3E%3CSPAN%3E1)%20whoami%20%2Fupn%20Run%20the%20command%20in%20commad%20prompt%20UPN%20should%20be%20same%20in%20cloud%26nbsp%3B.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%26nbsp%3B2)%20Add%20the%20URL%20in%20IE%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CDIV%20class%3D%22mceNonEditable%20lia-copypaste-placeholder%22%3E%26nbsp%3B%3C%2FDIV%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%222020-09-17%2023_38_32-Window.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F219306i6FE27586BB0775A1%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%222020-09-17%2023_38_32-Window.png%22%20alt%3D%222020-09-17%2023_38_32-Window.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%E2%80%83%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3E%C2%B7%26nbsp%3B%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fprotect-eu.mimecast.com%2Fs%2F7cNrC3yo2FVq0ytqUWXJ%3Fdomain%3Dnam06.safelinks.protection.outlook.com%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fenterpriseregistration.windows.net%3C%2FA%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%C2%B7%26nbsp%3B%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fprotect-eu.mimecast.com%2Fs%2Frta3C5Rq9tOE4Xu2Qph_%3Fdomain%3Dnam06.safelinks.protection.outlook.com%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Flogin.microsoftonline.com%3C%2FA%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%C2%B7%26nbsp%3B%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fprotect-eu.mimecast.com%2Fs%2FNYinC7pvLU9lo8uRKqKj%3Fdomain%3Dnam06.safelinks.protection.outlook.com%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdevice.login.microsoftonline.com%3C%2FA%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%C2%B7%26nbsp%3B%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fprotect-eu.mimecast.com%2Fs%2F8FAAC9DxQiPQ9lsZZskZ%3Fdomain%3Dnam06.safelinks.protection.outlook.com%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fautologon.microsoftazuread-sso.com%3C%2FA%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E3)%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3EOpen%20task%20scheduler(AS%20admin%20)%26gt%3B%20Microsoft%26gt%3BWindows%26gt%3B%20Work%20place%20join%26gt%3Bright%20click%20on%20%E2%80%9CAuto%20work%20place%20join%E2%80%9D%20and%20make%20sure%20it%20is%20in%20%E2%80%9Crunning%E2%80%9D%20state.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E4)%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3EThen%20re-start%20machine%20and%20run%20dsregcmd%20%2Fstatus%20%2C%20check%20for%26nbsp%3B%3CSPAN%20class%3D%22markiu65opws6%22%3EAzure%3C%2FSPAN%3E%26nbsp%3B%3CSPAN%20class%3D%22markvc3vssiir%22%3Eprt%3C%2FSPAN%3E%26nbsp%3Bstatus.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E5)%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3Edsregcmd%20%2Fdebug%20%2Fleave%20in%20admin%20mode.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E6)%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3EOnce%20machine%20up%20run%20dsregcmd%20%2Fdebug%20%2Fjoin%20in%20admin%20mode.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Regular Contributor

Hi All

 

I have successfully setup Hybrid Azure AD Join and I have implemented Auto-enrollment into Intune via GPO.

 

However, on my test user(s) I'm still getting MDM status = None.

 

Can anyone tell me what the User eXperience should be for this type of Intune Enrollment?

 

Does the User get prompted to sign in or anything?

 

Info appreciated

10 Replies
Highlighted

@Stuart King Could you please share some more information about your setup?

 

  1. What GPO settings did you apply?
  2. Is this not working for any machines that's joined to local AD?

When you set the gpo for device enrollment, the end machine will need to reboot and login. Once logged in, if you go to windows settings, you should see an info button on the work or school account which confirms that your machine is joined to Hybrid Azure AD.

 

Another way to check is to run the command dsregcmd /status.

More troubleshooting steps: https://docs.microsoft.com/en-us/azure/active-directory/devices/troubleshoot-hybrid-join-windows-cur...

Highlighted

@Ambarish RH 

 

Yes, the machines are showing as Hybrid Azure AD Join but not as enrolled in Intune.

 

Stuart

Highlighted

@Stuart King I had similar issues with on my tenant where devices will show in Azure AD Devices as Hybrid Azure AD Join but not in All Devices and the MDM state is shown as none. The fix for my case was to set 2 GPO policy settings (As per MS Support, the first device registration policy adds the device to Azure AD and MDM part enrolls the device to intune, and we need to have both to get the devices fully managed via intune/MDM)

 

clipboard_image_0.png

 

clipboard_image_0.png

 

If you do not see the policy, it may be because you don’t have the ADMX installed for Windows 10, version 1803 or version 1809. To fix the issue, follow these steps:

  1. Download:
    1803 -->Administrative Templates (.admx) for Windows 10 April 2018 Update (1803) or
    1809 --> Administrative Templates for Windows 10 October 2018 Update (1809).
  2. Install the package on the Primary Domain Controller (PDC).
  3. Navigate, depending on the version to the folder: 1803 --> C:\Program Files (x86)\Microsoft Group Policy\Windows 10 April 2018 Update (1803) v2, or
    1809 --> C:\Program Files (x86)\Microsoft Group Policy\Windows 10 October 2018 Update (1809) v2
  4. Copy policy definitions folder to C:\Windows\SYSVOL\domain\Policies.
  5. Restart the Primary Domain Controller for the policy to be available. This procedure will work for any future version as well.
Highlighted

@Ambarish RH 

 

That's very interesting, using the 2 GPO's.

 

I had that setup already, then removed the Device Registration one as I was advised that this was NOT needed for Hybrid Azure AD Join, as all domain devices register as Hybrid Azure AD Join once AADC has been configured this way.

 

I will re-implement the Device Registration policy and keep you posted.

 

Thanks again 

Highlighted

@Ambarish RH 

@Stuart King 

 

My environment is as follows:-

On Premise AD 

Hybrid Azure AD Joined devices using AD Connect

 

I was also facing the same situation where the status of the MDM was None rather than Microsoft Intune for my Windows 10 devices.

 

Ambarish I followed that extra step to Register domain joined computers as devices and now it seem to work. I would why this setting is needed given the device is already Hybrid Azure AD Joined?

 

Previously I did get this to work but only when the device was line of sight to my on premise AD. i.e. in the office.  So I thought that was just the limitation of auto enrolment.

 

Because all my users are now WFH due for COVID I will need to try this with some other devices but it now looks more positive. 

 

 

Highlighted

@Stuart King I have these problems every time. what I did is to run dsregcmd /status and see if the AzureADPRT value is NO. then if the value is NO, reboot the machine and login using the O365 account UPN (sample@contoso.com). It doesn't matter if it is the same with the on-premise AD UPN but you need to type the whole UPN name as login.  It will create a new profile and then go to work or school account and click on info. Once all the progress is successful, run the dsregcmd /status command again and see if the AzureADPRT value has changed.

Note: do not run cmd as administrator if you are applying the policy per user basis not on per device.

 

Also check the task scheduler of the affected machine. A successful Hybrid-joined device will automatically create a scheduled task. Also, check the event viewer for errors.

 

Hope this helps.

Highlighted

@Chris Yue It is actually required as part of the GPO Policy for Hybrid-joined devices. It should be worth noting that when configuring GPO for devices, you only need to change Computer Config policies and never duplicate the same policy on the User Config.

Here's a preview of mine.

Manual Policy configured.jpg

Highlighted

@almarlibetario 

 

Thanks for the tip.

On the articles I have seen, I saw reference to Enable automatic MDM enrolment using default Azure Ad but not the device registration one.

 

Another thing I have noticed is the following.

 

Where a user picture has been assigned to Office 365, which is visible in office.com and mobile apps, should this  appear on Windows 10 devices at the login screen?

 

I got this once, but since retiring the device and re-enrolling again, I don't see it anymore.

 

Highlighted

@Stuart King 

 

  1. Verify that the user who is going to enroll the device has a valid Intune license.
  2. Make sure that your auto-enrollment (MDM user scope to "All") settings are configured under Microsoft Intune instead of Microsoft Intune Enrollment.
  3. Verify that the Enable Automatic MDM enrollment using default Azure AD credentials group policy   (Computer Configuration > Policies > Administrative Templates > Windows Components > MDM) is properly deployed to all devices which should be enrolled into Intune.
  4. Verify that Microsoft Intune should allow enrollment of Windows devices (Device enrollment restrictions in Endpoint Manager portal)

 

Highlighted

I recently had another instance where the AzureAdPrt was NO, an MS support agent gave me the following steps:

1) whoami /upn Run the command in commad prompt UPN should be same in cloud .

 

 2) Add the URL in IE

 

2020-09-17 23_38_32-Window.png

 

·  https://enterpriseregistration.windows.net

·  https://login.microsoftonline.com

·  https://device.login.microsoftonline.com

·  https://autologon.microsoftazuread-sso.com

 

3)      Open task scheduler(AS admin )> Microsoft>Windows> Work place join>right click on “Auto work place join” and make sure it is in “running” state.

4)      Then re-start machine and run dsregcmd /status , check for Azure prt status.

5)      dsregcmd /debug /leave in admin mode.

6)      Once machine up run dsregcmd /debug /join in admin mode.