Intune APK Upload Error

Copper Contributor

Good morning.


Since Monday 8th June I have been unable to upload a private APK within our Intune Managed PlayStore portal. When uploading the APK file it errors, "Can't publish app. Try again in a few minutes."

The error message is very generic and suggests its just a system global error but it's been on going for a few days now. I have also tried uploading a previously successful APK file with the same error returned and several different browsers.


Is anyone else having this issue or has any idea on how to fix or contact for support?

11 Replies

Checked the certificates and versioning is in order?

Thank you for your reply @Rakibrahman 


Yes, the APK appears to be in the correct state. I also am unable to upload previously successful APKs which does suggest there is a global issue. Do you often upload private APKs to the Managed Playstore Console via Intune? Have you had any issues recently? 



last time was a month ago. Only issues were versioning. Every time you upload a new version of a app, it needs a higher version code. But nothing else.

@Rakibrahman Is your issue resolved? If yes how? Because we are also coming across same issue from last week. Please suggest what changes you have done.

@Prasad_Salvi I am also having the same issue trying to upload a 3rd party app thats not available on play store.

"Can't publish app. Try again in a few minutes." is all i get.
Been a few hours now.
I'm trying to upload a hik-connect app that is not available on play store... 

@ChrisNichols90 @Oderbang  @Prasad_Salvi Have you tried uploading it via the Google Play Console (Not within Intune)? You may get more detailed error information there. A quick way to get there would be to select the "Make Advanced Edits" link under the "Advanced Editing Options" section. I have found that directly logging into the Google Play console is much easier to work with and gives you a lot more functionality than using it through Intune. 

@_PRyan unfortunately I do not have a google play developer account, hence why accessing via intune (as you do not need one using this method) 

a dev account is required to access the play console as far as I'm aware.




@Oderbang You don't need to pay for one, when you add an app to the Private Google Play Store via Intune it creates a developer account for you. 

@_PRyan Perhaps that is the issue I am having then, this is the first app we are trying to upload. and there is no indication to the details of an account that has been automatically created as a "free developer" account.

I have tried logging into the google console using the same account that intune uses to sync the managed play store and no dice, it just asks me to pay for a dev account.

@Oderbang It has been a while since I added my first app, but I believe it was after I added an app to the Private store that I was able to click the "Make Advanced Edits" link. Once I clicked that, I think it logged me directly into the Google Play developer console. I then added my account I use to sync to the Google play store as an admin in the Google Play developer console for my organization. I am now able to log into the Google Play Console with that account and can add/update apps.


did anyone find a solution for this?

I am trying to upload Hik-Connect.apk as private app, but it does not work!