SOLVED

installing a exe but not working

Super Contributor

Hi all,

 

I am trying to install an emulator which is an exe with a license key but when installing it fails. 

 

I have been told that the install command is: 

Screenshot 2022-02-02 at 1.49.18 PM.png

 

But this doesnt seem to work via intune. 

 

I have packaged the .intunewin file pointing to the exe but no luck any ideas? 

 

 

47 Replies
I know :)... sandbox is indeed great for testing https://call4cloud.nl/2021/08/sandbox-multiverse-of-madness/

@Rudy_Ooms_MVP @Harm_Veenstra Thanks both I will look into this!

 

 

I mentioned you instead of @AB21805 :p I know you know :D
Thank you I will try this now. out of curiosity why %~dp0?
https://htipe.wordpress.com/2008/10/09/the-dp0-variable/ It's a variable for cmd files so that the whole path is prefixed, sometime apps install only using that

Hi @Rudy_Ooms_MVP @Harm_Veenstra 

 

I use Parallels on my mac so I can have windows 10 on it but I cant seem to install sandbox the feature doesnt seem to be there. 

 

I also tried Get-WindowsOptionalFeature -online -FeatureName Containers-DisposableClientVM

 

no error but still no sandbox

Are you using Windows 10 Home perhaps? It's installable from Windows 10 Pro build 1903 and up.

thats my issue haa thanks
Ok, if you have a Pro key.. You could upgrade it :) Not sure if things will actually work on your mac regarding Windows Sandbox... Never done that
Hi I am struggling to get the exe to install via the intunewin file so wanted to test using sandbox but on a device which isnt my mac i get this error Windows Sandbox cannot be installed, Virtualization support is disabled in the firmware

Any ideas on how to fix this or how I can get this intunewin file to install
Just adjust the install.cmd and upload the new version in the App, wait for it to install and check what it did and read logs in C:\programdata\Microsoft\IntuneManagementExtension\Logs.

Hi @Harm_Veenstra 

 

Screenshot 2022-02-03 at 1.56.22 PM.png

 

above is my new error! aha when trying to deploy. any ideas? 

Could be that it takes too long (60 minutes time-out) and that the installation in the background is prompting with a question.. Does anything happen on the test machine, do you see the installer in the taskmanager? is there a option in the installation command to output the progress in a log file which you could check?
Nothing in task manager. How do I get the install to ouput log files?

When running the install.cmd before packaging as the intunewin works fine on the test machine but when I package nothing installs.

And what do the logfiles mention about the installation?  (C:\programdata\Microsoft\IntuneManagementExtension\Log) Can you find any lines with the app name it and does it report something? Don't know if the application has a parameter in which you can specify a logfile?

<![LOG[[Win32App] This is a standalone app, id = b0756c67-cd43-452e-b2aa-edf51273c158, name = Class wiz 83Gt emulator]LOG]!><time="14:48:16.8843935" date="2-3-2022" component="IntuneManagementExtension" context="" type="1" thread="9" file="">
<![LOG[---->>[Win32App] Processing app (id=b0756c67-cd43-452e-b2aa-edf51273c158, name = Class wiz 83Gt emulator) with mode = DetectInstall]LOG]!><time="14:48:16.8843935" date="2-3-2022" component="IntuneManagementExtension" context="" type="2" thread="9" file="">
<![LOG[----[Win32App] app with name = Class wiz 83Gt emulator dependency detect only is False]LOG]!><time="14:48:16.8843935" date="2-3-2022" component="IntuneManagementExtension" context="" type="2" thread="9" file="">
<![LOG[[Win32App] ===Step=== Start to Present app b0756c67-cd43-452e-b2aa-edf51273c158]LOG]!><time="14:48:16.8853931" date="2-3-2022" component="IntuneManagementExtension" context="" type="1" thread="9" file="">
<![LOG[[Win32App] ===Step=== Detection rules]LOG]!><time="14:48:16.8853931" date="2-3-2022" component="IntuneManagementExtension" context="" type="1" thread="9" file="">
<![LOG[[Win32App] ProcessDetectionRules starts]LOG]!><time="14:48:16.8853931" date="2-3-2022" component="IntuneManagementExtension" context="" type="1" thread="9" file="">
<![LOG[[Win32App] ProcessDetectionRules Parsing InstallEx...]LOG]!><time="14:48:16.8863968" date="2-3-2022" component="IntuneManagementExtension" context="" type="1" thread="9" file="">
<![LOG[[Win32App] DetectionType 2]LOG]!><time="14:48:16.8863968" date="2-3-2022" component="IntuneManagementExtension" context="" type="1" thread="9" file="">
<![LOG[[Win32App] Start detectionManager SideCarFileDetectionManager]LOG]!><time="14:48:16.8863968" date="2-3-2022" component="IntuneManagementExtension" context="" type="1" thread="9" file="">
<![LOG[[Win32App] Disable Wow64FsRedirection]LOG]!><time="14:48:16.8873936" date="2-3-2022" component="IntuneManagementExtension" context="" type="1" thread="9" file="">
<![LOG[[Win32App] Path doesn't exists: C:\Program Files (x86)\CASIO applicationDetected: False]LOG]!><time="14:48:16.8873936" date="2-3-2022" component="IntuneManagementExtension" context="" type="2" thread="9" file="">
<![LOG[[Win32App] Checked under Path: C:\Program Files (x86)\, filePath:C:\Program Files (x86)\CASIO, agent was checking under expanded: C:\Program Files (x86)\CASIO, applicationDetected: False]LOG]!><time="14:48:16.8883959" date="2-3-2022" component="IntuneManagementExtension" context="" type="1" thread="9" file="">
<![LOG[[Win32App] Revert Wow64FsRedirection]LOG]!><time="14:48:16.8883959" date="2-3-2022" component="IntuneManagementExtension" context="" type="1" thread="9" file="">
<![LOG[[Win32App] detectionManager SideCarFileDetectionManager got applicationDetectedByCurrentRule: False as system]LOG]!><time="14:48:16.8883959" date="2-3-2022" component="IntuneManagementExtension" context="" type="1" thread="9" file="">
<![LOG[[Win32App] Completed detectionManager SideCarFileDetectionManager, applicationDetectedByCurrentRule: False]LOG]!><time="14:48:16.8883959" date="2-3-2022" component="IntuneManagementExtension" context="" type="1" thread="9" file="">
<![LOG[[Win32App] ===Step=== Check applicability]LOG]!><time="14:48:16.8893940" date="2-3-2022" component="IntuneManagementExtension" context="" type="1" thread="9" file="">
<![LOG[[Win32App] applicationRequirementMetadata.RequiredOSArchitecture is 0 or 3, skip check.]LOG]!><time="14:48:16.8893940" date="2-3-2022" component="IntuneManagementExtension" context="" type="1" thread="9" file="">
<![LOG[[Win32App] applicationRequirementMetadata expected version: 10.0.16299, client version: 10.0.19044, applicability: Applicable.]LOG]!><time="14:48:16.9117824" date="2-3-2022" component="IntuneManagementExtension" context="" type="1" thread="9" file="">
<![LOG[[Win32App] applicationRequirementMetadata.RequiredFreespace is , skip check.]LOG]!><time="14:48:16.9127812" date="2-3-2022" component="IntuneManagementExtension" context="" type="1" thread="9" file="">
<![LOG[[Win32App] applicationRequirementMetadata.RequiredMemory is , skip check.]LOG]!><time="14:48:16.9127812" date="2-3-2022" component="IntuneManagementExtension" context="" type="1" thread="9" file="">
<![LOG[[Win32App] applicationRequirementMetadata.RequiredCPUSpeed is , skip check.]LOG]!><time="14:48:16.9127812" date="2-3-2022" component="IntuneManagementExtension" context="" type="1" thread="9" file="">
<![LOG[[Win32App] applicationRequirementMetadata.MinimumNumberOfProcessors is , skip check.]LOG]!><time="14:48:16.9127812" date="2-3-2022" component="IntuneManagementExtension" context="" type="1" thread="9" file="">
<![LOG[[Win32App] ===Step=== Check Extended requirement rules]LOG]!><time="14:48:16.9138017" date="2-3-2022" component="IntuneManagementExtension" context="" type="1" thread="9" file="">
<![LOG[[Win32App] No ExtendedRequirementRules for this App. Skipping Check Extended requirement rule]LOG]!><time="14:48:16.9138017" date="2-3-2022" component="IntuneManagementExtension" context="" type="1" thread="9" file="">


does this make sense?
Ok, it checks for an already installed version of the app, doesn't find it in c:\program files (x86) and starts checking all requirements which you didn't specify other than a OS version and then it should start installing but the log ends there ;) What's behind this piece of log?
Getting this now:
Error unzipping downloaded content. (0x87D30067) for the fail message.

I have checked everything I get it to allow x86 and 64 bit. windows 1709 and later which the device has . install behaviour is system

Any more ideas? aha
Would it be possible for me to PM you the files somehow so you can test it your side?
You don't have AntiVirus running which blocks the file?