Hybrid join and device registered as username_windows_date_time instead of device name

Brass Contributor


I'm hybrid joining my company notebooks and have an issue with one of them; when I do all the operation to hybrid join the device, I see in Entra portal that it is hybrid joined but nothing more (only in 2 trial I've seen the owner field filled, the other like MDM and Security settings are empty).

On the Intune side, I see many entries that as name have username_windows_date_time as format instead of device name, so for example, instead of pc-something, I see marcomangiante_Windows_3/13/2024_10:01 AM

I tried many times to do an unjoin and a join (with instructions on link https://learn.microsoft.com/it-it/office/troubleshoot/activation/activation-error-0xcaa50021 in the section Leave and rejoin Microsoft Entra ID) but without luck.

Tried to do a research on search engine, some people have same issue but have found nothing, only that maybe the problem is the device.

Any help or suggestion?

2 Replies

@Marco Mangiante 
1.Always recommended to remove the older device entries of that device in intune before you do enroll.

2.Do check the config profile that you used to apply the name is succeed on that device

3.Do check the intune connector log to check the naming standard


Suresh M



thanks for your reply: I have other 18 devices that I do hybrid join without any issue and in the list in Intune are with the correct name; when I try to leave and then join again, I deleted all the entries in Intune, then done the leave, seen that in Entra ID devices list it come back as registered, then joined and in the list it appeared as hybrid join with the correct name, but as I said, without any other parameters.

Is it possible to scan Intune log or other resources to understand what happens? I also seen in AD events but I can't find nothing significant.