How to allow Citrix Workspace Receiver ICA launch from Kiosk Mode

Copper Contributor

Intune Windows 10 Multi App Kiosk mode does not allow to execute ICA file downloaded to access Citrix Apps.  ICA files are  not visible in the downloads folder, files are blocked as per the screenshot ! Citrix Workspace, Explorer, Chrome, Edge browsers are allowed in policy. Any suggestions to enable Citrix access from Kiosk ? Seems like a bug in Intune ! 



18 Replies

@pratikdave did you get this resolved? I am working on the same thing now

Can confirm we have the same issue. Not using the Kiosk works when logged in as a global Azure admin, but won't work when using a regular user account. Seems to be rights-related. It's not .ica that won't download, it's any file really. I tested with .docx and .xlsx but it 'Couldn't download' either. A .txt file will, though...

Good Day. We have the same issue, we are trying to allow Citrix to run when Kiosk Mode is applied to a workstation.
Has a Solution been found as we have logged calls with MS and they cant advise.

@Nicholas Fraser 


Hi we have this working now.


Let me know and I will help you. I actually have both versions working now Workspace App and via web ICA. 


rs6 rule now allows no restriction for the file explorer 


there is also a reg setting you can set on the client for the downloads folder





@p4ntb0y Sounds good, i'm not sure if we can use rs6 options as we do not fully confire these clients with application packages etc. I'm still curious how this played out for you, your help is welcome for sure.



rs6 rule? Sorry i didnt get it, would you please share the fix ? Thanks heaps in advance.



We neither understand what is "rs6" rule, please keep us posted if you find anything. Experiencing exactly the same issue. 



Here is the fix - HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Associations




Hi, how did you get this working?
I'm not able to get the citrix tile visible. We are able to download the ica files but not able to open the file.
So any idea or info is welcome :)

best regards


@QuintenDC1984 we decided to quit the Kiosk option. The restrictions made us decide a no-go for now, and we are going to use conventional GPO's.

I added every exe file from C:\Program Files (x86)\Citrix\ICA Client in the policy.
We open the storefront server with Chrome.
After logging in we can open a citrix session.
Only problem we are facing is that the start menu is opening after we start the citrix session to you have to click the citrix session on the taskbar.
It looks like when you close a program the startmenu will popup. And when you link the citrix session link op the SF website you open and close a few programs before you get the citrix session aswell.
Anyone know how the fix this?
So I hope I can resurrect this comment, especially since we finally were able to get Citrix working in kiosk mode through Endpoint Manager. I'm curious if anyone has any ideas on how to prevent the start menu to keep from popping up. It would be nice to figure out how we can get the Citrix session running without the workstation popping up the start menu every time it has to reload.
Hello, has this worked for you?
Hello, how did you do it?
I am in a similar boat, I was able to get the reg edit handled and can open the ica files. But applocker is blocking citrix from opening. I cannot figure out how to allow the other files that handle the ica, specifically wfcrun32.exe and wfica32.exe. I have found other sites that say we need to allow these, but in intune I cannot find a way. I can see how to allow citrix as that's an installed application, but since these are not installed, I cannot get the amuid for them. If someone can point me in a direction that would be much appreciated.


I added all of the exe files in the folder "C:\Program Files (x86)\Citrix\ICA Client\" in the kiosk configuration.Screenshot 2023-05-31 075207.png

I have the exact same issue i.e. users unable to launch Citrix based web apps.

I tried to do the same i.e. add these exe's as apps but they don't seem to appear on the tiles. Is that how you've set them i.e. Name 1, Desktop ID 1 and not Citrix.Workspace ?


We have autolaunch on chrome browser that has the homesite to the storefront site.