Microsoft Technical Takeoff: Windows and Microsoft Intune
Oct 24 2022 07:00 AM - Oct 27 2022 12:00 PM (PDT)

Getting error "We can't register this device now... "

Occasional Contributor

I have iPads enrolled in Intune with user affinity, the user is logged into the Company Portal. There is a notification in the Company Portal to "Register this device", when I tap it, it shows an error "We can't register this device now.  Try again later". I have tried to register over several days and still getting this error.

Any help with this is appreciated.


8 Replies



How many users are affected? Are all users affected or just some?
How many devices are affected? Are all devices affected or just some?

What is the IOS version on the device? Have you got the latest updates installed on devices?

What is the mobile device management authority set to ? Intune Standalone or Intune co-management?
If it's System Center Configuration Manager, what version of Configuration Manager are you using?

Have you checked the Device Cap?


Thank you



Hey @Deleted 

The issue is for newly enrolled devices, devices that have been enrolled and registered prior are not having an issue.

iOS versions 12.2 and 12.3.1 - there are a few iPads with the issue and the OS varies.

The MDM authority is Intune standalone.

We are not near are device limit at this point.







TBH what you explained to me all depends on your environment setup.
We have devices enrolled in our environment , we order one specific brand and also keep the OS updated on all devices.


As you said old devices are working fine and new devices are affected then you need to double-check changes made to your environment to identify the issue.

Another Example: to try to re-enrol a working device now to see if issue happens occurs again?
perform some checks on working and non-working devices. 


Thank you


@ralGoCanes the experience has changed in the Company Portal for iOS enrollment.  You do have to go under the device Settings now to complete the experience and might be getting a timeout if that step isn't being followed.


@Steve Bucci  We are also getting this same message.  I am familiar with the new iOS changes where you need to go to Settings > Profile to install the MDM profile.  I do that just fine and the device enrolls with CP however under notifications, it says, "register this device for full access to company resources".  As soon as I do that, it says it cannot register and try again later.  Not sure what is wrong.  Enrollment restrictions should not be causing this because I would not get this far if that was the issue.  Not sure what else it could be.

@ngo_admin I recommend opening a support ticket.

@ngo_admin Ever figure out the cause?  I'm seeing this issue as well during my Intune testing.  Thanks!

@ralGoCanes  I just dealt with this issue as well. It seems I had to removed devices from both Intune and Azure AD. This worked for me. I hope it works for you! :stareyes: