Fail to run powershell script

Iron Contributor

I have always been able to deploy and run powershell scripts to endpoint which is running a kiosk user-less deployment.


Recently, I tried to run a new script, which is a few simple lines of setting a few registry keys.

I am constantly failing because of the error "running script is disabled on the system".


FYI my other successful PS scripts are not registry related.


I have tried various ways of set-execution policy, it won't work when I tried to run the script locally.

From Intune, I tried a settings catologue profile to allow all scripts, won't work.


The error has always been "running scripts is disabled on the system". But my other non-registry related PS scripts all run fine.


Any idea?
Thanks all!

5 Replies
And you run those by using the Scripts pane in Intune? What are the settings for "Enforce script signature check"?
Any update?
Thanks for the response.

Whether I choose to use the script or remediation package from Intune, they both failed.
The "Enforce script signature check" is set to "No".
Remediation as user or System? What kind of Powershell security Configuration Profiles are there?
Did you manage to fix this?