Error deploying Visual Studio Code "System" Version in Intune

Copper Contributor



I have been trying to get a working deployment for Visual Studio Code going for the past 2 days. 
This has not been working at all so far and I tried pretty much anything I could think of.


For the System Installation I downloaded the System Installer from here:

Made the usual Package with the WinAppUtil.exe and uploaded it to Intune.


This how my Config looks like:

I tried the path as detection rule aswell as reg key.

Path would be C:\Program Files\Microsoft VS Code

I also tried both options for the association.


Nothing seems to work here. 

The Device gets the command to install the App but fails in the process with the following error message: 



1 Reply

At a glance this is because the install command is referencing the wrong file. Unless you renamed the installer it should be something like VSCodeSetup-x64-1.47.3.exe /VERYSILENT /NORESTART (or whatever the file downloaded from VS site is) .