Disable post OOBE screens Windows AutoPilot

Iron Contributor

Goodmorning all,


I'm building a new workplace concept with Windows AutoPilot. Everything is working fine, but I want to get rid of the post OOBE screens automatically and set the correct value for it.


The screens which I'm talking about are:

  • Do more with your voice
  • Let Microsoft and apps use your location
  • Find my device
  • Send diagnostic data to Microsoft
  • Improving inking & typing
  • Get tailored experiences with diagnostic data
  • Let's apps using advertising ID

Any suggestions on how I can configure this, is welcome!

You will be a live saver for me.





23 Replies

@Jeroen BurgerhoutHi Jeroen, I saw your message on LinkedIn.
How far are you with configuring Autopilot? If you have it correctly configured, you shouldn't see the (post) OOBE screens. I presume you have disabled OOBE in the Autopilot profile. ? 

It looks like your device is not add into Autopilot. Did you added the device into Autopilot based on a Powershell or did the manufacturer that for you? Did you assigned the profile to the group with Autopilot enabled devices? And do you see the device as an assigned device in the Autopilot profile?

@Albert Neef I have this in the AutoPilot Profile. It's a self-deploying kiosk device.Annotation 2019-12-12 130322.png

@Jeroen Burgerhout Ah oke.. Which version Windows are you using? Self-deploying is supported in 1903 and later.. Did you also enabled Enrollment Status Page (ESP) for this? 

@Albert Neef I'm testing it with 1909. And the Windows Enrollment settings are shown below.Annotation 2019-12-12 131539.png

Oke, looks good.. Can you find your autopilot device under Assigned Devices in the Autopilot profile? Did you try another (Internet)connection? Otherwise you have to check the evenvwr for the warnings.
You can find the log -> Microsoft-Windows-Provisioning-Diagnostics-Provider/AutoPilot

@Albert Neef I have the same on a direct internet connection. Device is assigned to the self-deploying profile. And no warnings or errors found in the eventvwr. And it's now called ModernDeployment-Diagnostics-Provider.

@Jeroen Burgerhout 


Hi Jeroen,

Got the exact same issue with a self-deploying machine. But I also see it with a hybrid joined machine, I raised a support call for it last week.

@HilbertHofsteenge Hybrid is still not supported and Self-deploying is in preview.. 


"Self-deploying mode does not support Active Directory Join or Hybrid Azure AD Join. All devices will be joined to Azure Active Directory."




@Albert Neef 

I know Albert ;)
But I use hybrid in user-driven mode.

@Jeroen Burgerhout  Hmm.. silly question: license? Are you using the Intune device license for this deployment? https://docs.microsoft.com/en-us/intune/fundamentals/licenses#additional-information

This one is required if you are using self-deploy for kiosk mode.



@Albert Neef 

Intune device license is meant for the 'bulk enrollment user', not for the machine itself. You cannot apply an 'Intune Device License' to a Device. At least it was 6 months ago explained by a Microsoft support guy ;)

@HilbertHofsteengeHmm... I don't think so. Device license is especially for Kiosk or public devices. You cannot manage a device without an Azure AD user account with the standard EMS/Microsoft 365 subscription. They are user-based license. This means also that you can not use Autopilot... That is the reason why Microsoft has introduced device-based licenses.


A quote from Micheal Niehaus:

"If you are deploying kiosks or digital signs using Intune, there is an available Intune device-only subscription license that can be used.  See the Intune licensing documentation for more around that."




@Jeroen Burgerhout 

I'm having the exact same problem. Autopilot config is the same as yours. And it does work. Autopilot comes up during OOBE, device gets joined to Intune and AzureAD, Apps get installed.


But when it should present the logon screen, or login for a kiosk device (according to https://docs.microsoft.com/en-us/windows/deployment/windows-autopilot/self-deploying#validation)

It shows all the privacy settings that we have to configure.

It also auto signs in to the device after I make the privacy settings selection, which also shouldn't happen as it is NOT a kiosk device (its just a shared user device)


I'm also using Windows 10 1909, but I'm using the Dutch version. Are you using the English version or also Dutch?


@Albert Neef 

The device based license should only be for Kiosk or digital sign machines. As you can also use self-deploying mode with shared user devices, or even personal devices if you wanted to (not sure why you would want that, but it could) it shouldn't have any impact on the autopilot experience.

@Roel Everink 

I'm using the English 1909 version, but with the Dutch region and language selected during OOBE.

@Jeroen Burgerhout In my environment I got it fixed. Support sent me a message that there was an issue solved in Windows Autopilot on 18 December 2019. But only for new autopilot profiles, not for existing profiles.

So I created new autopilot profiles and assigned them, after I didn't get any privacy questions anymore.

This issue solved the self-deploy (azuread only) and the user-driven (hybrid join) scenarion for me.


cc: @Albert Neef 

Hello @Hilbert Hofsteenge, Hi all,


I'm currently facing the same issue with the Windows 10 1909. As far as I remember it works a few month ago. Anyway... I tried to create a new Windows Autopilot profile but it doesn't change anything. after device deployment I still have the screens (Do more with your voice, etc...) displayed.

DId you change anything else to remove them?


Thanks in advance for your feedback!

Can the the "Dutch Intune support group" help out here please? :lol:


@Jeroen Burgerhout @Roel Everink @Albert Neef @Hilbert Hofsteenge 

Hi @Blobbx


I didn't tried this in the last months, so I can't answer your question. What I can do, is to make some time in my agenda to test it.

Will reply to you soon.


@JanBakkerOrphaned @Hilbert Hofsteenge

Hi @Blobbx 


I didn't see this issue anymore since the Intune fixed the autopilot profiles in December 2019.

At this moment we don't see any issue in our environment.


Are you sure the autopilot profile is assigned correctly? Try to take a look in the eventvwr


During OOBE:

- shift + F10

- eventvwr.exe

- Applications and Services Logs -> Microsoft -> Windows -> ModernDeployment-Diagnostics-Provider -> Autopilot


If the profile is assigned, try to raise a ticket at Intune support?


@JanBakkerOrphaned @Jeroen Burgerhout