Device Credential (0x0), Failed (A specific platform or version is not supported.)

New Contributor

Hello team,

 

Tried to enroll devices with Intune as GPO enrollment. Most of the device has been enrolled but some of the devices are getting this error. Auto MDM Enroll: Device Credential (0x0), Failed (A specific platform or version is not supported.)

Running Win10 Enterprise version. GPO is also enabled.

If someone can help me with the issue. Not sure devices if devices has bad SCCM entries.

 

Screenshot 2022-02-16 091044.png

 

Thank You

9 Replies
Thanks Rudy, Actually GPO is enabled as "User credentials" but still getting this error.

And with user credentials the error is the same I presume?

And I assume the user is in the mdm scope

And also no old enrollments like I also showed in the blog?

And does the scheduled task appears at the device?  make sure you open the task scheduler with sufficient permisisons

And anything useful in dsregcmd /status

 

A lots of and :) 

Yes, with user credentials same results.
User is in MDM scope as set to "All" in Intune.
I checked in enrollments folder in registries, Their is no old registries in there,
Scheduled task is also running and throwing the same error again and again.
with the dsregcmd /status commands, device is showing domain joined, azure joined, azure prt is set to yes and also receiving the MDM url's.

And what happens when you use a dsregcmd /join (system context)

And the registry values which are normally configured when configuring the gpo are also configured?

@Rudy_Ooms_MVP 

 

this command ran successfully.
and the registries are normal by default.

Just noticed the new error in task schedular:

 

2022-02-16_13-14-16.jpg

Thats odd kinda reminds of the error code you get when enrolling a device that is already in intune or when you have configured enrollment restrictions..

Hi Kundi215,

Did you confirm the device is not showing connected from Work Access or school account?
I have seen similar issue, removing and rejoining the domain has fixed the issue for me. Can you try it?

 

Moe

Hi,

That was one of my first ideas too, Thats why i asked if there are any leftovers of an older enrollment. But indeed rejoining the domain could fix it