Deploy EXE as Admin

%3CLINGO-SUB%20id%3D%22lingo-sub-1553212%22%20slang%3D%22en-US%22%3EDeploy%20EXE%20as%20Admin%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1553212%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20All%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20trying%20to%20deploy%20an%20EXE%20app%20via%20Intune%20(Packaged%20up%20in%20WinAppUtil)%2C%20however%20end%20users%20are%20getting%20prompted%20for%20admin%20creds%20to%20install.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20way%20around%20this%20at%20the%20app%20deploy%20level%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegards%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1553212%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EIntune%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMobile%20Device%20Management%20(MDM)%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1553311%22%20slang%3D%22en-US%22%3ERe%3A%20Deploy%20EXE%20as%20Admin%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1553311%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F131657%22%20target%3D%22_blank%22%3E%40Stuart%20King%3C%2FA%3E%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3EIf%20your%20Intune%20package%20needs%20admin%20privileges%20to%20be%20installed%2C%20you%20should%20install%20it%20under%20the%20system%20context%2C%20by%20selecting%20the%20correct%20%22%3CSPAN%3EInstall%20behavior%22.%20If%20you%20have%20selected%20%22User%22%2C%20the%20installation%20will%20run%20in%20the%20context%20of%20the%20logged-in%20user%20and%20the%20UAC%20will%20pop-up%20if%20it's%20activated.%3CBR%20%2F%3E%3C%2FSPAN%3EIf%20am%20I%20understanding%20your%20case%20correctly%2C%20I%20assume%20that%20the%20user%20is%20not%20admin%20on%20the%20device...%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22joel_grangier_0-1596033747355.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F208814iA21B67639CFC8A21%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22joel_grangier_0-1596033747355.png%22%20alt%3D%22joel_grangier_0-1596033747355.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1554800%22%20slang%3D%22en-US%22%3ERe%3A%20Deploy%20EXE%20as%20Admin%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1554800%22%20slang%3D%22en-US%22%3EHi%20There%3CBR%20%2F%3E%3CBR%20%2F%3EThe%20EXE%20is%20configured%20in%20Intune%20as%20Install%20Behavior%3A%20System%3CBR%20%2F%3E%3CBR%20%2F%3EAnd%20users%20are%20Standard%20Users.%3CBR%20%2F%3E%3CBR%20%2F%3EAny%20other%20ideas%3F%3C%2FLINGO-BODY%3E
Regular Contributor

Hi All

 

I'm trying to deploy an EXE app via Intune (Packaged up in WinAppUtil), however end users are getting prompted for admin creds to install.

 

Any way around this at the app deploy level?

 

Regards

2 Replies

@Stuart King 

If your Intune package needs admin privileges to be installed, you should install it under the system context, by selecting the correct "Install behavior". If you have selected "User", the installation will run in the context of the logged-in user and the UAC will pop-up if it's activated.
If am I understanding your case correctly, I assume that the user is not admin on the device...

joel_grangier_0-1596033747355.png

 

Hi There

The EXE is configured in Intune as Install Behavior: System

And users are Standard Users.

Any other ideas?