Tech Community Live: Microsoft Intune
Jun 22 2023, 07:30 AM - 11:30 AM (PDT)
Microsoft Tech Community

Company Portal (windows) stuck on installing

New Contributor


I am relatively new to Intune application deployment.

I have used the Intune exe to win32 tool to package .exe installers. This has worked fine for the most part.

I also have some applications which cannot be converted this way due to a complex install without any command-line arguments provided by the software vendors. So, I have been using a packaging tool in order to built .MSI's when needed.

I packaged a 2GB suite of applications into a single MSI, and attempted to deploy this via intune. 

Issue Encountered.

It simply won't install. I have checked the incoming folder and it's not there (but other test installs are). I have tried force closing the various process's intune uses to no avail. I have restarted my machine, still nothing.

I removed the application from being available on my device. This removed my ability to see the package within Intune, but I know it's still 'there' as my other test packages are stuck on pending and won't download.

To be clear, the problem package was on 'Installing' and had finished the 'downloading' portion already despite me being unable to find it in incoming.

How do I cancel this install so that I can continue to test other application packages that have been deployed? There is simply no simple way to do this that I can find.

3 Replies
best response confirmed by AsherLifeArc (New Contributor)

I needed to troubleshoot /reinstall a certain app multiple times... Part 4 of this blog will show you which reg keys you could remove the retrigger the installation
This worked perfectly. Deleted the AppID registry, restarted company portal and it moved onto the next packages in the queue.

Nice to hear! and thanx for replying back this was the solution!