Tech Community Live: Endpoint Manager edition
Jul 21 2022, 08:00 AM - 12:00 PM (PDT)

Company Portal doesnt show me Apps, Intune is not installing configuration files

Contributor

Hello,

 

We set up Intune recently, and I did a few set-ups before in previous companies.


After basics steps, now I want to use the Company Portal on my BYOD,

* App installation, good

* Profile installation, good

* also Branding from the company portal is appearing.

* but no apps are appearing, no configuration files are installed.

 

I set my BYOD into a group in AzureAD and set this group to the apps as "available", for the configuration files, as required.

 

I did manually trigger the sync, but nothing.
The device appears in the group, and under Troubleshooting and support, I can see my user, my device ,. and the apps which are assigned to me as a user, or for my mac.

 

Any hints here?

 

 

 

11 Replies

Just to be clear here... you're enrolling your macOS device in Intune via https://aka.ms/EnrollMyMac?

This appears to be successful, as you mention the profile and branding being applied.

 

Then, you expected the apps to appear on your device, right? You're only assigning them as "available", which would contradict that statement. "Available" apps don't install automatically, you would need to make them "Required" for that. 

 

Also, I'm not sure what you mean when you say "configuration files". Do you mean "configuration profiles", by any chance?

 

I apologize in advance if my questions sound "dumb". I'm just trying to get a clearer picture in my head. 

Hi @salihzett,

 

For available apps in the company portal, you must assign the app to a user group, otherwise, they will not be visible in the company portal.

 

Assign apps to groups in Microsoft Intune | Microsoft Docs

 

in your question, you mention also no configuration files are installed. Which configuration profiles do you mean and how did you assign those configuration profiles? 

 

Kind regards,

 

Rene

Hey,
yes I mean profiles, sorry, call them always config files :)

I did set them as available to see them under Apps into the Company Portal.
I even set one app as required, but also nothing.

I can sync, I can rename the mac, i can change the branding, but it looks like all settings regaring the group are not working, and i have no idea why.
Hey,
i set up a group, one manual, one dynamic (all macs from company), and I can see the devices as members of the group.
I have assigned this group to the apps and configuration profiles such as , enable filefault, but nothing happens here.

Hi @salihzett,

 

can you try to make a user group and assign that group to your config profiles and applications to test if that will work. So check if your group is setup correctly. 

 

So as you can also see in the documentation only available apps that are assign to a user group will be in the company portal. 

please let me know the results of assigning your config to a user group.

 

kind regards,

 

rene 

You mean to create a group and set users inside instead of devices?
Also did, same behavior.

Also here, i can see the members into the group, set the group for apps and profiles, but nothing.

When I look into the device, there is no profile pending, and for managed apps, it is "waiting".
but for more than 30 hours now.

I have tried scripts, also nothing.
Are you installing LOB or DMG apps?
If LOB, did you perform the troubleshooting as per https://docs.microsoft.com/en-us/troubleshoot/mem/intune/macos-lob-apps-not-deployed?
If DMG, is the Intune agent installed (in /Library/Intune/Microsoft Intune Agent.app)?
VPP, PKGs, nothing, all same.
I think this is a bug somewhere.

Same behavior for iPad/iOS Company Portal and VPP apps.

Hi @salihzett ,

 

what is the last sync date of the device. 
how did you enroll the device in intune? 

It’s look like your device isn’t connected with intune anymore. 

kind regards,

 

rene 

@Mr_Helaas 

 

Found the reason:
MDM - Authority was wrong, it was Office 365, changed to Intune, now it works as expected.

So weird.


Thanks everyone for helping.

Hi @salihzett,

 

thanks for your message and how you have fixed your problem.

 

Kind regards,

 

Rene