Can't Register devices in the iOS Comp Portal App

Occasional Visitor

We currently are facing issues in registering a device via the Comp Portal App on iOS. The same process however on our Android Devices seems to be working fine. 


We are getting the error: "We can't register this device now. Try again later"


Is there some configuration we changed that would cause this behavior.

5 Replies
Have you blocked personal iOS devices on your tenant?

@ShreyasHA you can always check enrollment errors for more details. Easiest way si through "Troubleshooting" section in Intune portal. Just select user you used for enrollment and it should show you errors.

It might not be the same problem, but I was receiving the same error recently when enrolling iOS devices.
It turns out the user account hit the device limit in Azure AD. I found out that devices in Azure AD aren't the same as devices in Intune. Same with the device limits.
Try checking the device limits you have in Azure AD and also any devices in Azure AD for the users with the problem.

@FredContrata112 Thank you, this solved my issue. I had to remove devices from both intune and Azure AD

It's a couple of years later, but this still applies and was helpful! I was doing some Configurator 2 based iOS device enrollment and was stumped as to why my latest test device failed to register. Turned out it was in fact the 20 device Azure AD limit. I had 20 devices under my name from 2018 till early this week. So glad you posted that, not sure how much longer I would have been poking around elsewhere before looking in Azure AD. None of the error messages hinted towards that Azure AD limit being hit.