Azure AD Join ERROR

Iron Contributor

I now changed it to Azure AD from Hybrid Azure AD. It looks like when I join through Azure AD as everything is configured as needed for this, I still get an error shown below.


I added the Intune Group that is going to be enrolling and wanting to join the Azure AD under Devices/Settings, but still it would not work. Maybe, I tried it immediately and it did not sync? Or what else could be the problem. This should be straight forward. 



6 Replies
Hi, coudl you give us some more info to go with? are you trying to reinstall a device that was already previously enrolled to haadj? did you removed the computer account on the ad so the azure ad object is removed after the sync? Did you checked who is allowed to enroll the device into azure ad?
Yes I was using the same device. Indelted the object in Azure as well as the computer objects in Osprey Ad. I might have to reimport the hash if and try.

We have 3 other users who have the permissions. Not me. Will that be a problem?

hi @oryxway ,


the user who logs on the device during autopilot registers the device in azure ad en must be able to register device in azure ad. 

I think this is your problem if I check your print screen  and your answers to @Rudy_Ooms_MVP 


kind regards,







Try checking the permissions setting described here: Azure AD Join error 801c03ed.


Please like or mark this thread as answered if it's helpful, thanks!

You can check multiple things for this.

- Already enrolled to Azure AD? > Try to remove the old computer object.
- Check Azure AD > Devices > Device settings > "Users may join devices to Azure AD"
- Also check maximum number of devices per user (what user are you using to join the device?)
- Check the sign-in logs of that specific user, maybe a conditional access rule is blocking the process.

@Kurt Mayer  Thanks for the info Kurt. I did check that and it looks good.