Apps not installing from ESP

Copper Contributor

I am having an issue with installing applications via my ESP in AutoPilot. 


During the build process, regardless of how many apps I have targeted in the ESP, it always reports as 1/1 installing. 


If I choose just one of my apps, and I've tried individually an MSI, EXE and Store app, neither are installed during the device setup. I have set the assignment on the app with various settings, namely available for the targeted device group, available for all users, required for the targeted device group and required for all devices.


Now, after the user registers and logins, applications are then installed but I am looking to get as many  applications installed for OOBE/Zero Touch to then reseal and deploy the device to the user, who then only has to login and create profile.


Help! tyia

21 Replies

1/1 --> is the IME (intune management extension)
Could you share with us which apps you configured as required? and how you assigned them
Are you sure the device gets the proper autopilot profile? do you have multiple autopilot profiles configured?
Do you have multiple ESP's ?

Esp Device phase --> device assignment (required)
Esp Account phase --> user assignment (required)


Nothing in the registry locations as mentioned here?

Troubleshoot the Enrollment Status Page (ESP) - Intune | Microsoft Docs


Did you configured the "Block device use until these required apps are installed if they are assigned to the user/device" in the ESP?
Also are their any other ESP profiles assigned to the device?
So I have 2 profiles, one for Hybrid and one for Azure. I can't get either to install apps.

Hybrid is assigned automatically via a dynamic AAD group, but by dropping my device into a 2nd AAD group I can switch over the Azure profile. I can see my device has been assigned the Azure profile under Enroll Devices.

I have tried a Win32App deployment of Google Chrome, which works fine as a normal deployment. And also a Windows Store app, o365 and an MSI install of Adobe Reader. None of them are being installed via CSP, or even being listed as 1 of X.
I guess the best recommendation would be to register a new ms365 for testing purposes and create only 1 autopilot profile first and configure the O365 apps as a required app and targetted to all devices. After that's done add the app to the list of required apps during the enrollment status page. And made sure this esp is targetted to all users and devices... And if that works... continue with the hybrid one.

Could you post screenshots from your ESP config/O365 app config/Autopilot config.
Without detailed info it would be just guessing whats wrong...
I have indeed, but the apps don;t install and the device is usable. And it muct be picking up the profile, as the device is named accordingly by the template
Diligent Boards is a Windows Store app, but as I said I've also tried with MSI/Win32.

I know i'm missing something very obvious......

I would start with the O365 apps assigning at a devicegroup (not dynamic to rule out the updating issue) Maybe using the filter option if needed.

And configuring that app as required during esp and start testing. If the device gets the correct autoprofile it must be installed


EDIT: Hybrid --> as in co management?  if so did you move the workloads?

Co-management workloads - Configuration Manager | Microsoft Docs

Cheers, I think I'll blow away the ESP and profiles and start from scratch. We've moved all workloads over to Intune and remain in co-managed state.

The device has to be picking up the correct config as it is being named as per the template.
I actually experience the same problem here.

I have created a new Autopilot deployment profile.
Added my computer to autopilot-service and added grouptag: Pilot
Created a dynamic devicegroup: (device.devicePhysicalIds -any _ -eq "[OrderID]:Pilot")
The computer gets added as member to group.

Assigned the dynamic group to Autopilot profile.
Assigned the dynamic group to 4 application as required.

None of the Required apps are installing in ESP, also tried setting " Block device use until apps are installed"

Also tried to assign the applications to "All devices" with filter: Include and rule:(device.enrollmentProfileName -eq "Pilot")

Same problem... not installing in ESP phase.

AADJ or HAADJ? And what happens without the filter?

Also just wondering but does the intune management extension get installed?

Do you have multiple autopilot profiles configured? if so are you sure it receives the one necessary 

AADJ only of course! ;)
I can't try without filter or group assignment because Intune is in production and have other devices so i must somehow assign those apps for my Pilot-devices!

I have also tried to assign the apps to my test-user and the problem is still there... in ESP the "Account setup" says No apps.... this have never been a issue before.
No apps.. thats odd.. at least is needs to install 1 off 1 (the IME if i am not mistaken)
Yes, correct. IME is installing under Device Account 1 of 1.
Just checking.. I am told we were experiencing this issue also yesterday.. today the same device... the apps were installing. Could you check if that's also the case at your side?
Yes i could check... found this blog/twitter feed yesterday that is almost exactly the same issue as described here BUT i'm using version for my Win32Apps :sad_but_relieved_face:
Nope, same problem.... this tenant is in China, tried same configuration and Win32apps in my lab-tenant in Europe and it works there...
Thanks everyone, I've been on leave for the last week or so & will give these replies a read through.
Hopefully get to the bottom of the issue without having to engage with MS Support (Or death by a million cuts :p )
Seems I've run into this issue as well with Autopilot Self-Deployment mode. I have one Win32 app assigned to the group which the deployment profile is also assigned to. When I run through ESP, I see 1 of 1 app being installed... Should be 1 of 2 (since Intune IME counts as one) I have my ESP config set to not continue until my one selected app is installed.

Anyone found a solution for this?