Android Enterprise devices failing to register

Copper Contributor

HI Wonder if anyone else is experiencing this.


We have a strange issue where Android Enterprise devices are failing to register for all users. The device installs authenticator and Intune and enforces our pin code policy and at the last step after the final login the device fails with a generic error. "Something went wrong"

Interestingly though after 1800 GMT the phones registered and it works ok up until after 0900 GMT when they start failing again. 

We are looking at stating to roll out over 200 devices and this is causing us no end of issues with sheduling. I have logged a cal with Microsoft but not gotten very far. Is anyone else having any issues?

22 Replies
Do you have any enrollment restrictions/Conditional ACcess policies in place?

@Thijs Lecomte  We do. We have restrictions in place to stop the enrollment of personal devices. Our enrolment is done via and MDM policy in Samsung Know that has the token for enrolment.


This has been working well up until we began to roll out devices. 


We just get the "something went wrong" retry error. When I checked this morning I am seeing devices in Intune marked as Not evaluated even though the device did not complete the registration process

Hi @Kanoni40 

Check ownership type and change to corporate if shows personal? Then give it another try.



best response confirmed by Kanoni40 (Copper Contributor)

I have exactly the same problem third day in a row. Intune enrollment does not work from 9 a.m. to 5 p.m everyday. 

@Kanoni40  We are having the same issue since yesterday. Android Enterprise devices (using QR during enrollment process) are failling. The device cannot be registered. This issue occurs using with all the devices and all the accounts...



Exactly the same. When I check back later on (say 4 hours) the devices show as registered and as not evaluated. I logged a call wit support but I'm not getting very far.

@miguelanyez  We are using Knox but its the same process. The devices fail. If you check back after a few hours you will see them registered in device management with not evaluated against them. Have you logged a call?


@Moe_Kinani When devices register they are fine as corporate. We use knox with the token in a MDM profile, so the devices register as corporate. This only fails between 0900 and 1800 GMT

We are having issues with this as well, Knox ->MDM->token->registers as corporate.

@Moe_Kinani We turned of the restriction for personal devices with microsoft and it still failed

@Kanoni40 we are having the same Issues since Monday 3rd. registered 2 before 9am GMT then stops working after 9am. 

@Kanoni40  we open a ticket with Microsoft and now the issue is solved "we had a service outage yesterday and should be solved. Check again"



I am also having issues with enrolled Samsung tablets in Intune, and if I attempt to re-enrol (after removing the work profile and reinstalling company portal) it does not work.


So I think there is an issue with Intune and Company Portal!


Check out my post here:

@miguelanyez Thankf for the info I'll try again after 9:00am. I logged a call with Microsoft too and have had nothing back. The problem I have is we are rolling out over 2000 devices to critical workers, so we kind of need a definitive answer from Microsoft that it is resolved .


In a weird way its good to know its not just us though

@Kanoni40 Hi tried a few devices there and they all successfully registered. I still haven't had official word from Microsoft that it has been resolved but its better than it was. We are going to try again in an hour to confirm.

Good evening. Has anyone received a definitive answer about this.

We are currently in the middle of a migration and finding this registration error issue on our SM-T807v (Samsung Galaxy Tab S) and SM-T567v (Samsung Galaxy Tab E) tablets.

I do have a ticket logged and we’re going through the formal troubleshooting steps over time.

Since we are wiping our devices out in the field, we’ve had to overnight new devices to users and are putting these migrations on hold for the time being for these two tablet types.

We’ve had success with a few of them from each tablet type but a majority of them are failing.

Thank you!

There doesn't seem to have been a reason stated as to why this happened. We are into the sixth week of a migration to Intune using KME and QR codes to enrol, and as of yesterday have seen this manifest. Our devices appear as Corporate (just tried re-wiping and enrolling a phone and I see it in Azure as Corporate). As the users are doing the enrolments, we cannot suggest before 09:00 or after 17:00. Would be grateful to find out if a fix was deployed, or if MS 'fessed up.
We've now got the same issue - We were able to enrol devices after 6pm, but not during the normal working hours.

Did Microsoft explain what the issue was and how they fixed it?

Have already got a case open with them, but might make it easier for them if we know what the fix was last time.

Thank you!
We have had a response from Microsoft.
"We've identified impact is due to delays in the enrollment process caused by a backlog of device association requests. We're running commands to optimize the processing of these requests to mitigate impact.
Scope of impact: Impact is specific to users who are served through the affected infrastructure.

I guess we will need to migrate less. Will ask for what numbers are acceptable.

hope this helps all others !
1 best response

Accepted Solutions
best response confirmed by Kanoni40 (Copper Contributor)

I have exactly the same problem third day in a row. Intune enrollment does not work from 9 a.m. to 5 p.m everyday. 

View solution in original post