Almost all devices show as Not Applicable in update rings

Copper Contributor

Currently almost all devices in our environment show not applicable in the standard windows update ring.  Newly added devices seem OK.

 

We previously used GPOs to push update settings.  As this was conflicting with the Intune settings, we disabled the GPOs.  Around that time (not sure exactly) our devices began showing not applicable for an update ring they were good with previously.

 

Anyone seen this/have any ideas?

4 Replies
gpo... lingering settings :).. did you checked this folder on those problem devices?
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU

If that one exists I would just clear out the trash in it :)
$registryPath = "HKLM:\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU"
Remove-Item -Path $registryPath -Recurse

@Rudy_Ooms_MVP   Tried that.  No effect.  Been working with MS for a while.  Not making progress.  It's odd that new machines work fine.  Older ones are OK too.  Just the ones that were used when we pulled the GPOs seem to be affected.  It seems like in pulling those GPOs removed some key that was need for Intune update.

@RodMarten917 

 

could you share maybe a bit more what you already tryed… otherwise we could do alot of guessing. :)

 

for example…  

https://techcommunity.microsoft.com/t5/intune-customer-success/support-tip-troubleshooting-windows-1...

I've been through that trouble shooting guide and a similar one earlier. I also have dropped all the GPO and Intune Update keys to no effect (Intune rebuilds it's keys) but seems to have an older ring's data (defer times are wrong). This appears that Intune is building on legacy data and not new data. Intune shows devices Not Applicable and it appears no new policies are applied.

I tried to get the registry key checks from MS support but that wasn't effective.

I'm thinking there is some underlying technology (Healthcheck?) that isn't working and that's the source, but the support is so silo'd It's hard to get any real troubleshooting.