Unable to get SSPR reports- Office 3565

%3CLINGO-SUB%20id%3D%22lingo-sub-1733307%22%20slang%3D%22en-US%22%3EUnable%20to%20get%20SSPR%20reports-%20Office%203565%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1733307%22%20slang%3D%22en-US%22%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20used%20to%20download%20usercredentialusagedetails%20through%20PS%20and%20it%20used%20to%20work%20fine%20until%20few%20weeks%20ago%20and%20now%20it%20fails.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EGET%20%3CA%20href%3D%22https%3A%2F%2Fgraph.microsoft.com%2Fbeta%2Freports%2FuserCredentialUsageDetails%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgraph.microsoft.com%2Fbeta%2Freports%2FuserCredentialUsageDetails%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fgraph%2Fapi%2Freportroot-list-usercredentialusagedetails%3Fview%3Dgraph-rest-beta%26amp%3Btabs%3Dhttp%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fgraph%2Fapi%2Freportroot-list-usercredentialusagedetails%3Fview%3Dgraph-rest-beta%26amp%3Btabs%3Dhttp%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CBR%20%2F%3EError%20%3A%3C%2FP%3E%3CP%3E%3CSPAN%3EInvoke-RestMethod%20%3A%20%7B%22%40odata.context%22%3A%22%3CA%20href%3D%22https%3A%2F%2Fgraph.microsoft.com%2Fbeta%2F%24metadata%23reports%2FuserCredentialUsageDetails%26quot%3B%2C%26quot%3Bv%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgraph.microsoft.com%2Fbeta%2F%24metadata%23reports%2FuserCredentialUsageDetails%22%2C%22v%3C%2FA%3E%20alue%22%3A%5B%7B%22id%22%3A%2279876725968494393786570221953037561096003605792378637660218099476724503735617%22%2C%22feature%22%3A%22registration%22%7B%20%22error%22%3A%20%7B%20%22code%22%3A%20%22InternalServerError%22%2C%20%22message%22%3A%20%22The%20property%20'userPrincipalName%5BNullable%3DFalse%5D'%20of%20type%20'Edm.String'%20has%20a%20null%20value%2C%20which%20is%20not%20allowed.%22%2C%20%22innerError%22%3A%20%7B%20%22date%22%3A%20%222020-09-30T11%3A58%3A11%22%2C%20%22request-id%22%3A%20%2260bdc1d7-054f-402b-8054-e0c8db709e43%22%2C%20%22client-request-id%22%3A%20%2260bdc1d7-054f-402b-8054-e0c8db709e43%22%20%7D%20%7D%20%7D%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHas%20anyone%20faced%20this%20issue%3F%20i%26nbsp%3B%20have%20number%20of%20other%20queries%2Frequests%20in%20same%20script%20and%20they%20all%20work%20fine.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1733384%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20get%20SSPR%20reports-%20Office%203565%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1733384%22%20slang%3D%22en-US%22%3E%3CP%3ESeems%20to%20work%20fine%20here%2C%20might%20have%20been%20a%20temp%20issue.%20If%20you%20are%20still%20running%20into%20it%2C%20best%20open%20a%20support%20case.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

 

I used to download usercredentialusagedetails through PS and it used to work fine until few weeks ago and now it fails.

 

GET https://graph.microsoft.com/beta/reports/userCredentialUsageDetails

 

https://docs.microsoft.com/en-us/graph/api/reportroot-list-usercredentialusagedetails?view=graph-res...

 


Error :

Invoke-RestMethod : {"@odata.context":"https://graph.microsoft.com/beta/$metadata#reports/userCredentialUsageDetails","v alue":[{"id":"79876725968494393786570221953037561096003605792378637660218099476724503735617","feature":"registration"{ "error": { "code": "InternalServerError", "message": "The property 'userPrincipalName[Nullable=False]' of type 'Edm.String' has a null value, which is not allowed.", "innerError": { "date": "2020-09-30T11:58:11", "request-id": "60bdc1d7-054f-402b-8054-e0c8db709e43", "client-request-id": "60bdc1d7-054f-402b-8054-e0c8db709e43" } } }

 

Has anyone faced this issue? i  have number of other queries/requests in same script and they all work fine.

 

2 Replies

Seems to work fine here, might have been a temp issue. If you are still running into it, best open a support case.

Highlighted

@Vasil Michev  Thanks for testing this out for me !! appreciated.

 

I tried this against 5 different tenancies and i am able to recreate this in all. Interesting !