HTTP requests handling files giving random (and incorrect) "Access denied" errors

Copper Contributor

I have been experiencing mysterious issues with my Logic Apps flow since yesterday. The flow does many, many things but all of the problems have something to do with files. 


1. Many of my file related HTTP requests suddenly stopped working, giving me "access denied" even though nothing in the flow had changed. I was using application rights and Active Directory OAuth as an authentication type. I solved this problem by using delegated rights and the authentication type Raw. So this one is somehow solved, though I think there is a deeper problem somewhere since it has been working for months until this.


2. I have a loop that renames ten files using PATCH. Out of the ten, roughly half of the files get renamed and the rest give me "access denied". Mind you, it is the same HTTP request in all of these cases, using the very same method of authentication. All of these files are in the same folder, have no unique user rights and have not been checked out. It is also completely random which files get renamed and which give access denied.


These examples are from the same run:


Access deniedAccess deniedNo error, business as usualNo error, business as usual


This flow is very critical to my client, and I am out of ideas how to fix it since the same requests works and... does not. 


Has anyone else experienced the same mysterious problem, or have any ideas of what I could try to fix this file renaming problem?

0 Replies