'Unknown User' showing when using Collaborate

%3CLINGO-SUB%20id%3D%22lingo-sub-1770922%22%20slang%3D%22en-US%22%3E'Unknown%20User'%20showing%20when%20using%20Collaborate%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1770922%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%20we've%20got%20Office%20365%20E3%20license.%26nbsp%3B%20I've%20started%20to%20use%20Forms%2C%20and%20wish%20to%20share%20(collaborate)%20with%20another%20user%20in%20my%20organisation.%26nbsp%3B%20Their%20name%20comes%20up%20when%20I%20start%20typing%2C%20which%20I%20then%20select%2C%20but%20afterwards%20it%20changes%20to%20Unknown%20User.%26nbsp%3B%20In%20addition%2C%20when%20I%20send%20the%20collaboration%20link%20they%20are%20not%20able%20to%20access%20the%20form%2C%20giving%20a%20message%20saying%20that%20they%20don't%20have%20permissions.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECould%20anyone%20please%20help%20me%20out%20with%20this%3F%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1770922%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EForms%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1780912%22%20slang%3D%22en-US%22%3ERe%3A%20'Unknown%20User'%20showing%20when%20using%20Collaborate%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1780912%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20having%20the%20same%20exact%20issue.%20Both%20users%20have%20Forms%20activated%20and%20in%20fact%2C%20the%20one%20sharing%20to%20collaborate%20is%20able%20to%20share%20with%20others%20that%20do%20have%20access.%20It's%20just%20one%20person%20that%20they%20share%20with%20that%20they%20show%20up%20as%2C%20%22Unknown%20User%22.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1814492%22%20slang%3D%22en-US%22%3ERe%3A%20'Unknown%20User'%20showing%20when%20using%20Collaborate%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1814492%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%20for%20the%20feedback.%20We%20will%20investigate%20to%20see%20whether%20there%20are%20any%20regressions%20in%20specific%20sharing.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1823096%22%20slang%3D%22en-US%22%3ERe%3A%20'Unknown%20User'%20showing%20when%20using%20Collaborate%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1823096%22%20slang%3D%22en-US%22%3E%3CP%3Esame%20issue%20here.%20I%20can%20select%20the%20user%20by%20email%20address%20to%20share%20but%20then%20it%20becomes%20Unknown%20user%3C%2FP%3E%3CDIV%20class%3D%22mceNonEditable%20lia-copypaste-placeholder%22%3E%26nbsp%3B%3C%2FDIV%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22uuser.jpg%22%20style%3D%22width%3A%20397px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F229526i1BE9C6637FD547D1%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22uuser.jpg%22%20alt%3D%22uuser.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1859854%22%20slang%3D%22en-US%22%3ERe%3A%20'Unknown%20User'%20showing%20when%20using%20Collaborate%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1859854%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F828885%22%20target%3D%22_blank%22%3E%40Thorlene%3C%2FA%3E%26nbsp%3BThank%20you%20for%20your%20feedback!%20If%20you%20can%20provide%20the%20requests%20har%20file%2C%20that%20won't%20be%20easier%20for%20us%20to%20root%20cause%20it.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Hi, we've got Office 365 E3 license.  I've started to use Forms, and wish to share (collaborate) with another user in my organisation.  Their name comes up when I start typing, which I then select, but afterwards it changes to Unknown User.  In addition, when I send the collaboration link they are not able to access the form, giving a message saying that they don't have permissions.

 

Could anyone please help me out with this?

Thanks

12 Replies

I'm having the same exact issue. Both users have Forms activated and in fact, the one sharing to collaborate is able to share with others that do have access. It's just one person that they share with that they show up as, "Unknown User".

Thanks for the feedback. We will investigate to see whether there are any regressions in specific sharing.

same issue here. I can select the user by email address to share but then it becomes Unknown user

 

uuser.jpg

@Thorlene Thank you for your feedback! If you can provide the requests har file, that won't be easier for us to root cause it. 

@Thorlene I suppose I got the same here. It's strange that some users can share among them, some could not in the organization. I wonder some credentials of some users have been corrupted.

@ChrisKJP Can you try to check if the user you want is belong to your organization or not? From what we observed that the user who is not belong to your org will be happened this issue. 

@CJZheng Thanks for your advice. I see no problem when I allow anyone in the organization to edit, which means anyone in the same organization can edit my form. I did encounter a problem when I allow only some people in the organization to edit but not open to all in the org. I didn't test if it happens when let the general public edit my form. I'll check that later.

for my issue, it happens with external registered B2B Azure users. They are registered users and it finds them in the dropdown but as soon as it saves it becomes Unkown Users

@FlowUser1 Thank you for your message, that exactly matched what we observed, and we just made the change to fix it. Hope it can light up by the end of this week and solve your problem

@CJZheng Thank you for your great fixing. Do you think you've fixed a case for in-house users of the organization? We look forward to seeing rolling it out to our end.

Apologies for not sending har file as requested, had a mad week, but thank you so much for fixing this. I tested it earlier and it’s working as expected now. Result!!
Stay safe all.

@Thorlene Great to know it's been fixed at your end. Unfortunately the glitch still exists here for sharing a form with some users in my organization.