Not Receiving eMail After Form is Submitted

%3CLINGO-SUB%20id%3D%22lingo-sub-2733171%22%20slang%3D%22en-US%22%3ENot%20Receiving%20eMail%20After%20Form%20is%20Submitted%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2733171%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'd%20like%20to%20thank%20you%20in%20advance%20for%20your%20assistance%2C%20but%20after%20trying%20for%20hours%20to%20tackle%20this%20issue%2C%20im%20at%20a%20dead%20end.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20created%20a%20form%20in%20Microsoft%20Forms.%26nbsp%3B%20Please%20see%20attached%20picture%20to%20view%20the%20form%20Settings%20in%20Microsoft%20Forms.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20using%20Power%20Automate%20to%20send%20a%20customized%20email%20to%20a%20user%20once%20the%20form%20is%20submitted.%20I%20am%20the%20creator%20of%20the%20form%20and%20when%20i%20preview%20the%20form%2C%20and%20fill%20in%20the%20information%20and%20submit%20it%20at%20the%20end%20for%20testing%2C%20the%20customized%20email%20gets%20sent%20and%20i%20receive%20it%20in%20m%20inbox%20no%20problem.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHowever%2C%20when%20another%20authorized%20user%20who%20the%20form%20has%20been%20shared%20with%20fills%20it%20out%2C%20the%20submission%20is%20successful%20and%20the%20respond%20can%20be%20viewed%20by%20me%20(the%20form%20creator).%20However%2C%20the%20email%20from%20power%20automate%20does%20not%20get%20sent%20at%20all.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20i%20run%20the%20flow%20check%20in%20power%20automate%20it%20says%20the%20flows%20are%20fine%20and%20no%20errors%20are%20displayed.%20when%20i%20save%20the%20flow%20it%20says%20the%20flow%20has%20been%20saved%20successfully%20and%20it%20should%20work%20and%20when%20itest%20it%20myself%2C%20everything%20works%20wonderfully.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPlease%20take%20a%20look%20at%20the%20screen%20shots%20to%20see%20the%20power%20automate%20settings%2C%20the%20Microsoft%20Forms%20settings%2C%20and%20the%20actual%20form%20itself.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20desperately%20hope%20someone%20could%20help%20shine%20some%20light%20on%20this.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETHANKS%20A%20MILLION%20IN%20ADAVANCE.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2733171%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EForms%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Forms%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EPower%20Apps%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EPower%20Automate%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EPower%20Automate%20Approvals%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2733553%22%20slang%3D%22en-US%22%3ERe%3A%20Not%20Receiving%20eMail%20After%20Form%20is%20Submitted%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2733553%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1149990%22%20target%3D%22_blank%22%3E%40katzgroup%3C%2FA%3E%26nbsp%3Ban%20email%20will%20only%20be%20sent%20from%20an%20account%20where%20the%20user%20has%20send%20as%2Fsend%20on%20behalf%20of%20privileges.%20This%20is%20why%20at%20my%20company%20we%20always%20use%20Send%20an%20email%20from%20a%20shared%20mailbox%20and%20not%20Send%20an%20email%20(v2).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERob%3CBR%20%2F%3ELos%20Gallardos%3CBR%20%2F%3E%3CFONT%20size%3D%222%22%20color%3D%22%23006400%22%3EMicrosoft%20Power%20Automate%20Community%20Super%20User%3C%2FFONT%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2733586%22%20slang%3D%22en-US%22%3ERe%3A%20Not%20Receiving%20eMail%20After%20Form%20is%20Submitted%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2733586%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1149990%22%20target%3D%22_blank%22%3E%40katzgroup%3C%2FA%3E%26nbsp%3Byou%20can't%20user%20Responder's%20email%20in%20the%20Send%20as%20unless%20you%20have%20permissions%20to%20send%20from%20that%20responder's%20email%20account.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERob%3CBR%20%2F%3ELos%20Gallardos%3CBR%20%2F%3E%3CFONT%20size%3D%222%22%20color%3D%22%23006400%22%3EMicrosoft%20Power%20Automate%20Community%20Super%20User%3C%2FFONT%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Hello,

 

I'd like to thank you in advance for your assistance, but after trying for hours to tackle this issue, im at a dead end.

 

I have created a form in Microsoft Forms.  Please see attached picture to view the form Settings in Microsoft Forms.

 

I am using Power Automate to send a customized email to a user once the form is submitted. I am the creator of the form and when i preview the form, and fill in the information and submit it at the end for testing, the customized email gets sent and i receive it in m inbox no problem.

 

However, when another authorized user who the form has been shared with fills it out, the submission is successful and the respond can be viewed by me (the form creator). However, the email from power automate does not get sent at all.

 

When i run the flow check in power automate it says the flows are fine and no errors are displayed. when i save the flow it says the flow has been saved successfully and it should work and when itest it myself, everything works wonderfully.

 

Please take a look at the screen shots to see the power automate settings, the Microsoft Forms settings, and the actual form itself.

 

I desperately hope someone could help shine some light on this.

 

THANKS A MILLION IN ADAVANCE.

1 Reply

@katzgroup you can't user Responder's email in the Send as unless you have permissions to send from that responder's email account.

 

Rob
Los Gallardos
Microsoft Power Automate Community Super User